summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-01-03 15:30:31 +0200
committerTor Lillqvist <tml@iki.fi>2013-01-03 20:21:51 +0200
commit449d657b10446e77b388ff01d4f595b50ecf7c49 (patch)
treeff72eb769d452ec12e0395e0ed0dfb1066ae1c35 /configure.ac
parentMore hacking on an iOS "Viewer" app that doesn't do much anything yet (diff)
downloadcore-449d657b10446e77b388ff01d4f595b50ecf7c49.tar.gz
core-449d657b10446e77b388ff01d4f595b50ecf7c49.zip
Don't do dynamic lib tests when we aren't going to build such
Change-Id: I3190fba16638512dbc4247fa3fa95c39fa377b34
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c60ae0115062..9f9527d67f99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5708,7 +5708,9 @@ istringstream strm( "test" ); return 0;
LDFLAGS=$sharedlink_ldflags_save
fi
- if test "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE" -a "$HAVE_GCC_VISIBILITY_BROKEN" != "TRUE"; then
+ # As the below test checks things when linking self-compiled dynamic libraries, it presumably is irrelevant
+ # when we don't make any dynamic libraries?
+ if test "$DISABLE_DYNLOADING" = "" -a "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE" -a "$HAVE_GCC_VISIBILITY_BROKEN" != "TRUE"; then
AC_MSG_CHECKING([if gcc is -fvisibility-inlines-hidden safe (Clang bug 11250)])
cat > conftestlib1.cc <<_ACEOF
template<typename T> struct S1 { virtual ~S1() {} virtual void f() {} };