summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-01-01 08:47:36 +0100
committerDavid Tardon <dtardon@redhat.com>2013-01-01 09:02:06 +0100
commit3f22967547f529e46651c9247d696dd7668943dc (patch)
treeb2f701c580e9be58c94315f0a05216e63ed3cf52 /configure.ac
parentalways set library path (diff)
downloadcore-3f22967547f529e46651c9247d696dd7668943dc.tar.gz
core-3f22967547f529e46651c9247d696dd7668943dc.zip
fail early if python version cannot be determined
Change-Id: I8fea82f8d4f779b0e7f8550fb67b794d6ae913ba
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8428abccb7ca..643f2320bead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7546,6 +7546,11 @@ if test $enable_python = system; then
break
fi
done
+ AC_MSG_CHECKING([for python version])
+ AS_IF([test -n "$PYTHON_VERSION"],
+ [AC_MSG_RESULT([$PYTHON_VERSION])],
+ [AC_MSG_RESULT([not found])
+ AC_MSG_ERROR([no usable python found])])
test -n "$PYTHON_CFLAGS" && break
fi
fi