summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-01-07 14:40:51 +0200
committerTor Lillqvist <tlillqvist@suse.com>2013-01-07 14:44:06 +0200
commit37c6106f3a74f249cd421454d20f8ce561f71eb0 (patch)
tree4a260fc89132c076657083b705f814a8fd2e28dc /configure.ac
parentRevert "Clang doesn't like that ToolPanelFactory::~ToolPanelFactory() is prot... (diff)
downloadcore-37c6106f3a74f249cd421454d20f8ce561f71eb0.tar.gz
core-37c6106f3a74f249cd421454d20f8ce561f71eb0.zip
Since 6eff6fae6272e8ed5d74553597bb4b73db3f2864 Python needed on Windows
Change-Id: Id49730b7ad2f7122a2c9b0415330b6fb803ec21c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a1fd05a4184..2fa044ffd097 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7415,12 +7415,18 @@ AC_MSG_CHECKING([which Python to use])
case "$enable_python" in
no|disable)
+ if test $build_os = cygwin; then
+ # Python is required to build nss. In theory we could separate the build-time Python
+ # requirement from the choice whether to include Python stuff in the installer, but why
+ # bother?
+ AC_MSG_ERROR([Python is required at build time when building on Windows])
+ fi
enable_python=no
AC_MSG_RESULT([none])
DISABLE_PYTHON=TRUE
;;
""|yes|auto)
- if test "$DISABLE_SCRIPTING" = TRUE; then
+ if test "$DISABLE_SCRIPTING" = TRUE -a $build_os != cygwin; then
AC_MSG_RESULT([no, overridden by --disable-scripting])
enable_python=no
DISABLE_PYTHON=TRUE