summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-01-02 15:18:11 +0200
committerTor Lillqvist <tml@iki.fi>2013-01-02 19:25:28 +0200
commit2210bade74626de68e51adb9759b81f62d7c0b01 (patch)
tree5b8435f9c8e07e60ae0f7789d10e0256b293c37a /configure.ac
parentsal: missing jvmfwk in log-areas (diff)
downloadcore-2210bade74626de68e51adb9759b81f62d7c0b01.tar.gz
core-2210bade74626de68e51adb9759b81f62d7c0b01.zip
Check also for a (self-built) 64-bit NDK tool-chain
Also make the --with-android-ndk-toolchain-version option mandatory. Otherwise it would be possible to leave it out and that would appear to work in the configure phase but in fact mix stuff up when using a self-built 64-bit tool-chain merged into a r8b,c,d NDK. Sigh, maybe we shouldn't even try to have the configury generic enough to work with any NDK version (which probably it doesn't anyway), but explicitly accept only a small set of NDKs, like r8b,c,d (which probably are the only that we work with anyway). Change-Id: Iecdf3a2d841e7b29598228ae49f48eca9640a82c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dbcaf6603bcb..af1b7862ae6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,7 +154,24 @@ if test -n "$with_android_ndk"; then
android_cpu=x86
fi
- ANDROID_ABI_PREBUILT_BIN=`echo $ANDROID_NDK_HOME/toolchains/$android_cpu*-*$with_android_ndk_toolchain_version/prebuilt/*/bin`
+ # Check if there is a (self-built) 64-bit tool-chain
+ toolchain_system='*'
+ if test $build_os = linux-gnu; then
+ case $build_cpu in
+ x86_64)
+ case "`echo $ANDROID_NDK_HOME/toolchains/$android_cpu*-*$with_android_ndk_toolchain_version/prebuilt/linux-x86_64/bin`" in
+ */bin|*/bin\ */bin*)
+ toolchain_system=linux-x86_64
+ ;;
+ esac
+ ;;
+ i?86|x86)
+ toolchain_system=linux-x86
+ ;;
+ esac
+ fi
+
+ ANDROID_ABI_PREBUILT_BIN=`echo $ANDROID_NDK_HOME/toolchains/$android_cpu*-*$with_android_ndk_toolchain_version/prebuilt/$toolchain_system/bin`
# Check if there are several toolchain versions
case "$ANDROID_ABI_PREBUILT_BIN" in
*/bin\ */bin*)
@@ -489,6 +506,10 @@ linux-android*)
AC_MSG_ERROR([the --with-android-ndk option is mandatory])
fi
+ if test -z "$with_android_ndk_toolchain_version"; then
+ AC_MSG_ERROR([the --with-android-ndk-toolchain-version option is mandatory])
+ fi
+
if test -z "$with_android_sdk"; then
AC_MSG_ERROR([the --with-android-sdk option is mandatory])
fi