summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2020-11-07 17:51:27 +0100
committerMichael Stahl <michael.stahl@cib.de>2020-11-07 18:52:07 +0100
commit03a9a80125cf887d26348486b71d78d80c99344d (patch)
tree1ca67adb707e66c0f2a0088abd0c9e82ac0f2e45 /configure.ac
parentScriptForge - Fix typos (diff)
downloadcore-03a9a80125cf887d26348486b71d78d80c99344d.tar.gz
core-03a9a80125cf887d26348486b71d78d80c99344d.zip
configure: OpenSSL needs perl-FindBin to build
Change-Id: Idcea17d2418a2e847a5713293d7a225ed86bd305 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/105435 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4ff24f35b2b1..cd7af465d660 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5994,6 +5994,10 @@ fi
if test "$with_system_hsqldb" = "yes"; then
perl_use_string="$perl_use_string ; use Archive::Zip"
fi
+if test "$with_system_openssl" != "yes"; then
+ # OpenSSL needs that to build
+ perl_use_string="$perl_use_string ; use FindBin"
+fi
if $PERL -e "$perl_use_string">/dev/null 2>&1; then
AC_MSG_RESULT([all modules found])
else