summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2021-10-26 23:40:47 +0200
committerLuboš Luňák <l.lunak@collabora.com>2021-10-27 15:02:11 +0200
commitef42ce579f0e4e4c436f70615f3adeb9f0f68217 (patch)
treeb688259454d3b571831bc3dd706ec3c974dd1f45 /configure.ac
parentremove highlight when mouse tracking is finished (diff)
downloadcore-ef42ce579f0e4e4c436f70615f3adeb9f0f68217.tar.gz
core-ef42ce579f0e4e4c436f70615f3adeb9f0f68217.zip
fix AVX512 detection
The value wasn't in config_host.mk.in, so it's never been used. And also fix Calc Kahan CPU-specific code yet again :( . Change-Id: Iacfd500e5a662b2b4b96a009d129a012d278a3ad Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124248 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index adf6da19b1f9..a810ba0b88af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7808,6 +7808,9 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <immintrin.h>
int main () {
__m512i a = _mm512_loadu_si512(0);
+ __m512d v1 = _mm512_load_pd(0);
+ // https://gcc.gnu.org/git/?p=gcc.git;a=commit;f=gcc/config/i386/avx512fintrin.h;h=23bce99cbe7016a04e14c2163ed3fe6a5a64f4e2
+ __m512d v2 = _mm512_abs_pd(v1);
return 0;
}
])],
@@ -12281,6 +12284,9 @@ if test "$ENABLE_SKIA" = TRUE -a "$COM_IS_CLANG" != TRUE; then
#include <immintrin.h>
int main () {
__m512i a = _mm512_loadu_si512(0);
+ __m512d v1 = _mm512_load_pd(0);
+ // https://gcc.gnu.org/git/?p=gcc.git;a=commit;f=gcc/config/i386/avx512fintrin.h;h=23bce99cbe7016a04e14c2163ed3fe6a5a64f4e2
+ __m512d v2 = _mm512_abs_pd(v1);
return 0;
}
])],