summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-11-05 08:20:01 +0100
committerStephan Bergmann <sbergman@redhat.com>2021-11-05 09:35:31 +0100
commit9ee124ac454177c85d7e928a35d2b533dac33d9c (patch)
tree7d6c7a512ca91b67e196bfe365ea1329aa4163e5 /configure.ac
parentsw: remove useless debug code in SwLangHelper (diff)
downloadcore-9ee124ac454177c85d7e928a35d2b533dac33d9c.tar.gz
core-9ee124ac454177c85d7e928a35d2b533dac33d9c.zip
Simplify code checking for Boost < 1.50
...after 0b9a6cfc443d84158fb0db6f40b953e1410178d8 "Set Boost baseline to 1.66, and enforce it" Change-Id: Ia3b1c453872cdcf4830160de4bbd500b178b7834 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124726 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 2 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 112b82b14384..6144dab8ba48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10649,27 +10649,11 @@ dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.17 >= 0.17.0])
if test "$with_system_orcus" != "yes"; then
if test "$SYSTEM_BOOST" = "TRUE"; then
- # ===========================================================
- # Determine if we are going to need to link with Boost.System
- # ===========================================================
+ dnl Link with Boost.System
dnl This seems to be necessary since boost 1.50 (1.48 does not need it,
dnl 1.49 is untested). The macro BOOST_THREAD_DONT_USE_SYSTEM mentioned
dnl in documentation has no effect.
- AC_MSG_CHECKING([if we need to link with Boost.System])
- AC_LANG_PUSH([C++])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- @%:@include <boost/version.hpp>
- ]],[[
- #if BOOST_VERSION >= 105000
- # error yes, we need to link with Boost.System
- #endif
- ]])],[
- AC_MSG_RESULT([no])
- ],[
- AC_MSG_RESULT([yes])
- AX_BOOST_SYSTEM
- ])
- AC_LANG_POP([C++])
+ AX_BOOST_SYSTEM
fi
fi
dnl FIXME by renaming SYSTEM_LIBORCUS to SYSTEM_ORCUS in the build system world