summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-11-04 11:03:11 +0100
committerStephan Bergmann <sbergman@redhat.com>2021-11-04 12:49:44 +0100
commit7158acde7756a264c09e24e1cfe4c81db700b920 (patch)
treee9bc75e50e405f61ef37fbd2f9cef40d364a9505 /configure.ac
parentRTF import: fix too small graphic size when both picwgoal and picw are provided (diff)
downloadcore-7158acde7756a264c09e24e1cfe4c81db700b920.tar.gz
core-7158acde7756a264c09e24e1cfe4c81db700b920.zip
Consolidate -D_GLIBCXX_DEBUG for --enable-dbgutil builds against libstdc++
(this was meant as a prerequisite for enabling its -D_LIBCPP_DEBUG=1 counterpart when building against libc++ on macOS, but which got stalled for now after running into the issue described at <https://lists.llvm.org/pipermail/libcxx-dev/2021-October/001222.html> "[libcxx-dev] Building a program with -D_LIBCPP_DEBUG=1 against a libc++ that is not itself built with that define") Change-Id: If466dce595a9311b2afbae41d5ddcaecc6f3c57b Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124678 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2a831da535a..112b82b14384 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7126,6 +7126,7 @@ dnl Identify the C++ library
dnl ===================================================================
AC_MSG_CHECKING([what the C++ library is])
+HAVE_LIBSTDCPP=
AC_LANG_PUSH([C++])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <utility>
@@ -7135,6 +7136,7 @@ foo bar
]])],
[CPP_LIBRARY=GLIBCXX
cpp_library_name="GNU libstdc++"
+ HAVE_LIBSTDCPP=TRUE
],
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <utility>
@@ -7158,6 +7160,7 @@ foo bar
AC_MSG_ERROR([Could not figure out what C++ library this is]))))
AC_MSG_RESULT([$cpp_library_name])
AC_LANG_POP([C++])
+AC_SUBST([HAVE_LIBSTDCPP])
dnl ===================================================================
dnl Check for gperf