summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2021-10-27 13:28:58 +0300
committerTor Lillqvist <tml@collabora.com>2021-10-27 13:49:00 +0200
commit71b227dfa46fbc9fbf9b9f2046705939ab0a02bf (patch)
tree4e11088c1b7b05c4e1a6780fedeb3e9c2fe29096 /configure.ac
parentRemove lines that have been ifdeffed out since 2008 (diff)
downloadcore-71b227dfa46fbc9fbf9b9f2046705939ab0a02bf.tar.gz
core-71b227dfa46fbc9fbf9b9f2046705939ab0a02bf.zip
Accept macOS SDK 12.0
Change-Id: I3e2b004578394e0199ac425f7b80da47a668f70d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124266 Tested-by: Tor Lillqvist <tml@collabora.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f5ec60327f03..adf6da19b1f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3251,7 +3251,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-11.3 11.1 11.0 10.15 10.14 10.13}; do
+ for _macosx_sdk in ${with_macosx_sdk-12.0 11.3 11.1 11.0 10.15 10.14 10.13}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -3289,8 +3289,11 @@ if test $_os = Darwin; then
11.3)
MACOSX_SDK_VERSION=110300
;;
+ 12.0)
+ MACOSX_SDK_VERSION=120000
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.3])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--12.0])
;;
esac
@@ -3358,8 +3361,11 @@ if test $_os = Darwin; then
11.3)
MAC_OS_X_VERSION_MIN_REQUIRED="110300"
;;
+ 12.0)
+ MAC_OS_X_VERSION_MIN_REQUIRED="120000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.3])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--12.0])
;;
esac
@@ -3426,8 +3432,11 @@ if test $_os = Darwin; then
11.3)
MAC_OS_X_VERSION_MAX_ALLOWED="110300"
;;
+ 12.0)
+ MAC_OS_X_VERSION_MAX_ALLOWED="120000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.3])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--12.0])
;;
esac