summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-04-29 19:40:14 +0200
committerThorsten Behrens <thorsten.behrens@allotropia.de>2021-05-05 21:16:23 +0200
commit27cc1d10421777469c89cd1ec30229643b1a03ea (patch)
tree79c7df8c90970a04f71962172ad42ae1914015ad /configure.ac
parentWASM: add distro config, amend readme (diff)
downloadcore-27cc1d10421777469c89cd1ec30229643b1a03ea.tar.gz
core-27cc1d10421777469c89cd1ec30229643b1a03ea.zip
Add --enable-wasm-strip
Will just set enable wasm strip for cross-target Change-Id: I0840b843794e4fab694df26608619a7bf06f5e5f Reviewed-on: https://gerrit.libreoffice.org/c/core/+/114981 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a9e42031ae1..44ea1276283c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1895,6 +1895,12 @@ AC_ARG_ENABLE(curl,
[Disable CURL support.]),
,enable_curl=yes)
+AC_ARG_ENABLE(wasm-strip,
+ AS_HELP_STRING([--enable-wasm-strip],
+ [Strip the static build like for WASM/emscripten platform.]),
+,enable_wasm_strip=yes)
+
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -3721,13 +3727,19 @@ if test "$_os" = "iOS" -o "$build_cpu" != "$host_cpu"; then
cross_compiling="yes"
fi
fi
+
+ENABLE_WASM_STRIP=''
if test "$cross_compiling" = "yes"; then
export CROSS_COMPILING=TRUE
+ if test "$enable_dynamic_loading" != yes -a "$enable_wasm_strip" = yes; then
+ ENABLE_WASM_STRIP=TRUE
+ fi
else
CROSS_COMPILING=
BUILD_TYPE="$BUILD_TYPE NATIVE"
fi
AC_SUBST(CROSS_COMPILING)
+AC_SUBST(ENABLE_WASM_STRIP)
# Use -isystem (gcc) if possible, to avoid warnings in 3rd party headers.
# NOTE: must _not_ be used for bundled external libraries!
@@ -5302,6 +5314,7 @@ if test "$cross_compiling" = "yes"; then
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
test "$with_galleries" = "no" -o -z "$WITH_GALLERY_BUILD" && sub_conf_opts="$sub_conf_opts --with-galleries=no"
+ test "$enable_wasm_strip" = "yes" && sub_conf_opts="$sub_conf_opts --enable-wasm-strip"
sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
# Don't bother having configure look for stuff not needed for the build platform anyway