summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2021-05-28 13:52:37 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2021-05-28 20:28:17 +0200
commit07556be594c77f9b7886ff31c2e1752f937cacd4 (patch)
treebac4a0b2fb2618345e6b920351fecdc130e00920 /configure.ac
parentMissing include (diff)
downloadcore-07556be594c77f9b7886ff31c2e1752f937cacd4.tar.gz
core-07556be594c77f9b7886ff31c2e1752f937cacd4.zip
Select svl crypto backend in configure.ac
And define USE_CRYPTO_* macros to select it in code. This way we can get rid of all the HAVE_FEATURE_NSS and _WIN32 variations. This also reverts 1f6b98f21495f0ecc5ded493cb3273da03852191. Change-Id: I101e4ae2f49cdb127d59bd49a4f1c86304ca2238 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116338 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c4dc0c5545fe..7a1ef29ee9ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -804,6 +804,7 @@ dnl Sequential to keep the logic very simple
dnl These values may be checked and reset later.
dnl ===================================================================
#defaults unless the os test overrides this:
+build_crypto=yes
test_cmis=yes
test_curl=yes
test_randr=yes
@@ -962,6 +963,7 @@ darwin*|macos*) # macOS
;;
ios*) # iOS
+ build_crypto=no
test_cmis=no
test_randr=no
test_xrender=no
@@ -1071,6 +1073,7 @@ dragonfly*)
;;
linux-android*)
+ build_crypto=no
build_gstreamer_1_0=no
enable_lotuswordpro=no
enable_mpl_subset=yes
@@ -10290,7 +10293,6 @@ if test "$enable_fuzzers" != "yes" -a "$enable_nss" = "yes"; then
libo_CHECK_SYSTEM_MODULE([nss],[NSS],[nss >= 3.9.3 nspr >= 4.8])
AC_DEFINE(HAVE_FEATURE_NSS)
ENABLE_NSS=TRUE
- AC_DEFINE(ENABLE_NSS)
elif test $_os != iOS ; then
with_tls=openssl
fi
@@ -10864,6 +10866,20 @@ fi
AC_SUBST([ENABLE_CIPHER_OPENSSL_BACKEND])
dnl ===================================================================
+dnl Select the crypto backends used by LO
+dnl ===================================================================
+
+if test "$build_crypto" = yes; then
+ if test "$OS" = WNT; then
+ BUILD_TARGET="$BUILD_TARGET CRYPTO_MSCAPI"
+ AC_DEFINE([USE_CRYPTO_MSCAPI])
+ elif test "$ENABLE_NSS" = TRUE; then
+ BUILD_TARGET="$BUILD_TARGET CRYPTO_NSS"
+ AC_DEFINE([USE_CRYPTO_NSS])
+ fi
+fi
+
+dnl ===================================================================
dnl Check for building gnutls
dnl ===================================================================
AC_MSG_CHECKING([whether to use gnutls])
@@ -14253,6 +14269,7 @@ AC_CONFIG_FILES([config_host.mk
AC_CONFIG_HEADERS([config_host/config_buildid.h])
AC_CONFIG_HEADERS([config_host/config_box2d.h])
AC_CONFIG_HEADERS([config_host/config_clang.h])
+AC_CONFIG_HEADERS([config_host/config_crypto.h])
AC_CONFIG_HEADERS([config_host/config_dconf.h])
AC_CONFIG_HEADERS([config_host/config_eot.h])
AC_CONFIG_HEADERS([config_host/config_extensions.h])