summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-08-07 07:57:12 +0200
committerStephan Bergmann <sbergman@redhat.com>2017-08-07 07:57:12 +0200
commitd031f9e24f01369a836370a785538fdba28d7cc1 (patch)
tree11edfb4aa0a1a316c85f58f39317e2c336a07cfa /configure.ac
parentRevert "accessibility: remove useless calls to getAccessibleActionCount." (diff)
downloadcore-d031f9e24f01369a836370a785538fdba28d7cc1.tar.gz
core-d031f9e24f01369a836370a785538fdba28d7cc1.zip
Allow MSGFMT, MSGUNIQ to be overridden
...and fail already in configure when only MSGFMT but not MSGUNIQ is overridden Change-Id: I5dadca9f44f46e830b8321be11deaa4252f5b596
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 20 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index c925914405fc..490d03e058cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11594,21 +11594,28 @@ if test -z "$WITH_LANG" -o "$WITH_LANG" = "en-US"; then
else
AC_MSG_RESULT([$WITH_LANG])
GIT_NEEDED_SUBMODULES="translations $GIT_NEEDED_SUBMODULES"
- if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/msgfmt" ; then
- MSGFMT="$LODE_HOME/opt/bin/msgfmt"
- MSGUNIQ="$LODE_HOME/opt/bin/msguniq"
- elif test -x "/opt/lo/bin/msgfmt"; then
- MSGFMT="/opt/lo/bin/msgfmt"
- MSGUNIQ="/opt/lo/bin/msguniq"
- fi
if test -z "$MSGFMT"; then
- AC_CHECK_PROGS(MSGFMT, [msgfmt])
- if test -z "$MSGFMT"; then
- AC_MSG_ERROR([msgfmt not found. Install GNU gettext, or re-run without languages.])
+ if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/msgfmt" ; then
+ MSGFMT="$LODE_HOME/opt/bin/msgfmt"
+ elif test -x "/opt/lo/bin/msgfmt"; then
+ MSGFMT="/opt/lo/bin/msgfmt"
+ else
+ AC_CHECK_PROGS(MSGFMT, [msgfmt])
+ if test -z "$MSGFMT"; then
+ AC_MSG_ERROR([msgfmt not found. Install GNU gettext, or re-run without languages.])
+ fi
fi
- AC_CHECK_PROGS(MSGUNIQ, [msguniq])
- if test -z "$MSGUNIQ"; then
- AC_MSG_ERROR([msguniq not found. Install GNU gettext, or re-run without languages.])
+ fi
+ if test -z "$MSGUNIQ"; then
+ if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/msguniq" ; then
+ MSGUNIQ="$LODE_HOME/opt/bin/msguniq"
+ elif test -x "/opt/lo/bin/msguniq"; then
+ MSGUNIQ="/opt/lo/bin/msguniq"
+ else
+ AC_CHECK_PROGS(MSGUNIQ, [msguniq])
+ if test -z "$MSGUNIQ"; then
+ AC_MSG_ERROR([msguniq not found. Install GNU gettext, or re-run without languages.])
+ fi
fi
fi
fi