summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorbrainbreaker <gautamprajapati06@gmail.com>2017-07-27 18:21:55 +0530
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-08-01 15:40:58 +0200
commit7f369c730a7e6ab834f67c294e4091378f3b99ce (patch)
tree2bd820fdcbfca03a2a5046ee66f2e62d12680678 /configure.ac
parentfix aqua build (diff)
downloadcore-7f369c730a7e6ab834f67c294e4091378f3b99ce.tar.gz
core-7f369c730a7e6ab834f67c294e4091378f3b99ce.zip
android: remove unused GCC related code from configure.ac
Change-Id: Ib54e31a4d01721fbb47e3c9f63d3a7c6a6b53a8f Reviewed-on: https://gerrit.libreoffice.org/40488 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 51f336a9b83f..962cc2591733 100644
--- a/configure.ac
+++ b/configure.ac
@@ -351,7 +351,7 @@ AC_ARG_WITH(android-ndk,
AC_ARG_WITH(android-ndk-toolchain-version,
AS_HELP_STRING([--with-android-ndk-toolchain-version],
[Specify which toolchain version to use, of those present in the
- Android NDK you are using. The default is 4.9 currently.]), ,)
+ Android NDK you are using. The default is clang 5.0 currently.]), ,)
AC_ARG_WITH(android-sdk,
AS_HELP_STRING([--with-android-sdk],
@@ -530,9 +530,9 @@ if test -n "$with_android_ndk"; then
test -z "$RANLIB" && RANLIB=$ANDROID_BINUTILS_BIN/$android_gnu_prefix-ranlib
test -z "$STRIP" && STRIP=$ANDROID_BINUTILS_BIN/$android_gnu_prefix-strip
- # When using the 4.6 or newer toolchain, use the gold linker
+ # When using the clang toolchain, use the gold linker
case "$with_android_ndk_toolchain_version" in
- 4.[[6789]]*|[[56789]].*|clang*)
+ clang*)
if test "$host_cpu" = arm -a "$ENABLE_LTO" != TRUE; then
ANDROIDCFLAGS="$ANDROIDCFLAGS -fuse-ld=gold"
fi
@@ -566,18 +566,12 @@ if test -n "$with_android_ndk"; then
if test -z "$CC"; then
case "$with_android_ndk_toolchain_version" in
- 4.*)
- CC="$ANDROID_COMPILER_BIN/$android_gnu_prefix-gcc $ANDROIDCFLAGS"
- ;;
clang*)
CC="$ANDROID_COMPILER_BIN/clang $ANDROIDCFLAGS"
esac
fi
if test -z "$CXX"; then
case "$with_android_ndk_toolchain_version" in
- 4.*)
- CXX="$ANDROID_COMPILER_BIN/$android_gnu_prefix-g++ $ANDROIDCXXFLAGS"
- ;;
clang*)
CXX="$ANDROID_COMPILER_BIN/clang++ $ANDROIDCXXFLAGS"
;;