summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-07-24 15:11:57 +0200
committerMichael Stahl <mstahl@redhat.com>2017-07-24 15:12:52 +0200
commit68d7faae7d748b6adcf8ba71a5b7ec9d80031c1b (patch)
tree1c585b2722548ed2dabc2b3a66b872514b3927a2 /configure.ac
parentloplugin:unusedfields readonly fields (diff)
downloadcore-68d7faae7d748b6adcf8ba71a5b7ec9d80031c1b.tar.gz
core-68d7faae7d748b6adcf8ba71a5b7ec9d80031c1b.zip
configure: check that msgfmt/msguniq were actually found
Change-Id: I6134b01644bf156154256ba5c4ad64ff5acd0f1d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0e4c9b80d29..cc4f11844b28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11598,7 +11598,13 @@ else
fi
if test -z "$MSGFMT"; then
AC_CHECK_PROGS(MSGFMT, [msgfmt])
+ if test -z "$MSGFMT"; then
+ AC_MSG_ERROR([msgfmt not found. Install GNU gettext, or re-run without languages.])
+ fi
AC_CHECK_PROGS(MSGUNIQ, [msguniq])
+ if test -z "$MSGUNIQ"; then
+ AC_MSG_ERROR([msguniq not found. Install GNU gettext, or re-run without languages.])
+ fi
fi
fi
AC_SUBST(MSGFMT)