summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2015-10-29 12:17:40 +0100
committerStephan Bergmann <sbergman@redhat.com>2015-10-29 13:02:40 +0000
commita346dfccd7e342d776dd59eb3ed128557e22a1bf (patch)
treefd2b7dcb940e054bdc080afed3b52257c9e4ca84 /configure.ac
parentsolenv: hack to maybe fix WNT instset creation (diff)
downloadcore-a346dfccd7e342d776dd59eb3ed128557e22a1bf.tar.gz
core-a346dfccd7e342d776dd59eb3ed128557e22a1bf.zip
tdf#70833: IDNA support when exporing hyperlinks to PDF
Any URLs using non-ASCII IDNA syntax need to be resolved to ASCII-only, as PDF URI Action's URI needs to be "encoded in 7-bit ASCII." Introduce URIHelper::resolveIdnaHost (svl/urihelper.hxx), which internally uses icu::IDNA, which requires to bump the minimal --with-system-icu requirement from 4.2 to 4.6, which means ICU_RECLASSIFIED_CLOSE_PARENTHESIS is always true now. Change-Id: I0e20d9a20ed2b869fba0cc7c969721411db590b3 Reviewed-on: https://gerrit.libreoffice.org/19669 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 50003a650224..4a7f6b357917 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8949,7 +8949,6 @@ SYSTEM_GENCMN=
ICU_MAJOR=56
ICU_MINOR=1
-ICU_RECLASSIFIED_CLOSE_PARENTHESIS="TRUE"
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="TRUE"
ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER="TRUE"
ICU_RECLASSIFIED_HEBREW_LETTER="TRUE"
@@ -8974,10 +8973,10 @@ if test "$with_system_icu" = "yes"; then
ICU_MAJOR=`echo $ICU_VERSION | cut -d"." -f1`
ICU_MINOR=`echo $ICU_VERSION | cut -d"." -f2`
- if test "$ICU_MAJOR" -ge "49" -o \( "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "2" \); then
+ if test "$ICU_MAJOR" -ge "49" -o \( "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "6" \); then
AC_MSG_RESULT([OK, $ICU_VERSION])
else
- AC_MSG_ERROR([not suitable, only >= 4.2 supported currently])
+ AC_MSG_ERROR([not suitable, only >= 4.6 supported currently])
fi
fi
@@ -9013,11 +9012,6 @@ You can use --with-system-icu-for-build=force to use it anyway.])
if test -z "$SYSTEM_GENCMN"; then
AC_MSG_ERROR([\'gencmn\' not found in \$PATH, install the icu development tool \'gencmn\'])
fi
- if test "$ICU_MAJOR" -ge "49" -o \( "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4" \); then
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="TRUE"
- else
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS=
- fi
if test "$ICU_MAJOR" -ge "49"; then
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="TRUE"
ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER="TRUE"
@@ -9055,7 +9049,6 @@ AC_SUBST(SYSTEM_GENCCODE)
AC_SUBST(SYSTEM_GENCMN)
AC_SUBST(ICU_MAJOR)
AC_SUBST(ICU_MINOR)
-AC_SUBST(ICU_RECLASSIFIED_CLOSE_PARENTHESIS)
AC_SUBST(ICU_RECLASSIFIED_PREPEND_SET_EMPTY)
AC_SUBST(ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER)
AC_SUBST(ICU_RECLASSIFIED_HEBREW_LETTER)