summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-12-13 16:52:50 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-12-17 16:34:23 +0100
commit77d3777c8934171a9557a96872d020cf12443fb9 (patch)
tree405281132307da4125f32651aee78e19ed47b34b /configure.ac
parentOUString::reverseCompareTo() string literal overload to match the AsciiL one (diff)
downloadcore-77d3777c8934171a9557a96872d020cf12443fb9.tar.gz
core-77d3777c8934171a9557a96872d020cf12443fb9.zip
Remove --with-stlport from LO 4.0
The STLport was only built for the benefit of old extensions on platforms that once used it themselves (Linux x86, Solaris x86 and SPARC, Windows). We deliberately break such old extensions for LO 4.0 by no longer shipping that backwards-compatiblity cludge. Keeps STLport listed in readlicense_oo/ because of o3tl/inc/o3tl/compat_functionality.hxx. Also removes GXX_INCLUDE_PATH, as that was only used by STLport (if at all?). Removes a spurious #define MOVEFILE_REPLACE_EXISTING 0x01 from l10ntools/inc/helpmerge.hxx that was once added with 854812584862d0609b695682d2bfea2667d75c00 "INTEGRATION: CWS extensionl10nfix01 (1.11.6); FILE MERGED: 2008/06/26 13:56:03 ihi 1.11.6.1: #i90987# windows rename -> MoveFileEx" but now starts to cause trouble on Windows. Also disables warning C4005 about redefinition of WB_LEFT/RIGHT macros (defined in both tools/wintypes.hxx and the Windows API) in a number of places that include windows.h -- however the old STLport caused those warnings to not show. Change-Id: Ie138a219fbbc86fb5aaa7ea0b88cf349935d9829
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac103
1 files changed, 2 insertions, 101 deletions
diff --git a/configure.ac b/configure.ac
index 29462cd522c9..2e9983be0350 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1664,13 +1664,6 @@ AC_ARG_WITH(linker-hash-style,
Possible values: "sysv", "gnu", "both". The default value is "gnu"
if supported on the build system, and "sysv" otherwise.]))
-AC_ARG_WITH(stlport,
- AS_HELP_STRING([--with-stlport],
- [Build the STLPort library for compatibility with old extensions for
- architectures where STLPort used to be used.]),
- with_stlport=$withval ,
-with_stlport=auto)
-
AC_ARG_WITH(jdk-home,
AS_HELP_STRING([--with-jdk-home],
[If you have installed JDK 1.3 or later on your system please supply the
@@ -1681,15 +1674,6 @@ AC_ARG_WITH(jdk-home,
],
,)
-AC_ARG_WITH(gxx_include_path,
- AS_HELP_STRING([--with-gxx-include-path],
- [If you want to override the autodetected g++ include path.])
- [
- Usage: --with-gxx-include-path=<absolute path to
- g++ include dir>
- ],
-,)
-
AC_ARG_WITH(help,
AS_HELP_STRING([--without-help],
[Disable the build of help.]))
@@ -4201,9 +4185,9 @@ if test "$cross_compiling" = "yes"; then
test -f ./config_host.mk 2>/dev/null || exit
cp config_host.mk ../config_build.mk
cp config.log ../config.Build.log
- . ./bin/get_config_variables COM GUI GUIBASE OS PATH CPU CPUNAME CC CXX DISABLE_PYTHON GXX_INCLUDE_PATH MACOSX_DEPLOYMENT_TARGET INPATH OUTPATH PYTHON SYSTEM_LIBXSLT OUTDIR SOLARINC SOLARLIB WORKDIR
+ . ./bin/get_config_variables COM GUI GUIBASE OS PATH CPU CPUNAME CC CXX DISABLE_PYTHON MACOSX_DEPLOYMENT_TARGET INPATH OUTPATH PYTHON SYSTEM_LIBXSLT OUTDIR SOLARINC SOLARLIB WORKDIR
- for V in COM GUI GUIBASE OS CPU CPUNAME CC CXX DISABLE_PYTHON GXX_INCLUDE_PATH MACOSX_DEPLOYMENT_TARGET INPATH OUTPATH \
+ for V in COM GUI GUIBASE OS CPU CPUNAME CC CXX DISABLE_PYTHON MACOSX_DEPLOYMENT_TARGET INPATH OUTPATH \
PYTHON SYSTEM_LIBXSLT; do
VV='$'$V
VV=`eval "echo $VV"`
@@ -5464,89 +5448,6 @@ EXCEPTIONS="$exceptions_type"
AC_SUBST(EXCEPTIONS)
dnl ===================================================================
-dnl Checks for what the default STL should be
-dnl ===================================================================
-AC_MSG_CHECKING([Whether building STLPort library makes sense])
-BUILD_STLPORT="no"
-if test "$_os" = "Linux"; then
- case "$host_cpu" in
- i?86)
- case "$host_os" in
- k*bsd*-gnu*)
- BUILD_STLPORT="no"
- ;;
- *)
- BUILD_STLPORT="yes"
- ;;
- esac
- ;;
- *)
- BUILD_STLPORT="no"
- ;;
- esac
-elif test "$_os" = "SunOS" -a "$COM" = "C52"; then
- BUILD_STLPORT="yes"
-elif test "$_os" = "WINNT" -a "$CPUNAME" != X86_64 -a "$WITH_MINGW" != "yes"; then
- BUILD_STLPORT="yes"
-elif test "$_os" = "FreeBSD"; then
- BUILD_STLPORT="yes"
-fi
-if test "$BUILD_STLPORT" = "yes"; then
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-AC_MSG_CHECKING([Whether STLPort library will be actually built])
-if test "$with_stlport" = "auto" -o "$BUILD_STLPORT" = "no"; then
- with_stlport=$BUILD_STLPORT
-fi
-if test "$with_stlport" = "yes"; then
- AC_MSG_RESULT([yes])
- WITH_STLPORT=YES
- SCPDEFS="$SCPDEFS -DWITH_STLPORT"
- BUILD_TYPE="$BUILD_TYPE STLPORT"
-else
- WITH_STLPORT=NO
- AC_MSG_RESULT([no])
-fi
-
-AC_SUBST(WITH_STLPORT)
-
-dnl ===================================================================
-dnl gxx include directories needed by STLPort
-dnl ===================================================================
-# Removed the special FreeBSD treatment. The problem was that with_gxx_include_path
-# often contains an i386 which is expanded as a macro.
-if test "$GXX" = "yes"; then
- AC_MSG_CHECKING([for g++ include path])
- if test -z "$with_gxx_include_path"; then
- with_gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - 2>/dev/null | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -n 1`
- if test "$with_gxx_include_path" = "/usr/libexec/(null)/include"; then
- with_gxx_include_path="/usr/include"
- fi
- if echo $with_gxx_include_path | $GREP -q linux; then
- # workaround for Mandriva - issue 100049
- with_gxx_include_path=`cd -P $with_gxx_include_path && pwd`
- fi
- fi
- dnl This is the original code...
- dnl with_gxx_include_path=`$CXX -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
- if test -z "$with_gxx_include_path"; then
- with_gxx_include_path="NO_GXX_INCLUDE"
- AC_MSG_RESULT([none])
- else
- PathFormat "$with_gxx_include_path"
- with_gxx_include_path="$formatted_path"
- AC_MSG_RESULT([$with_gxx_include_path])
- fi
-else
- with_gxx_include_path="NO_GXX_INCLUDE"
-fi
-GXX_INCLUDE_PATH="$with_gxx_include_path"
-AC_SUBST(GXX_INCLUDE_PATH)
-
-dnl ===================================================================
dnl thread-safe statics
dnl ===================================================================
AC_MSG_CHECKING([whether $CXX supports thread safe statics])