summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-04-24 09:05:09 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-04-24 11:09:57 +0200
commitd365f36331874f94bbd9832fbd19ace90fafefec (patch)
tree4d459ff87c402b6f2a6496173664688bb3328cd4 /configure.ac
parentsimplify call sites of SfxItemPool::Put (diff)
downloadcore-d365f36331874f94bbd9832fbd19ace90fafefec.tar.gz
core-d365f36331874f94bbd9832fbd19ace90fafefec.zip
Allow to pass JAVA_SOURCE/TARGET_VER into configure
...for those who pretend they know what they are doing (e.g., to experiment with building against Java 12 which no longer supports Java 1.6 source/target, even though that results in a build that is not baseline compatible). Change-Id: I6e8617bc5b90212473652bdfac40bb48e9623a08 Reviewed-on: https://gerrit.libreoffice.org/71218 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 567746177490..9d010de28280 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7203,8 +7203,8 @@ dnl Checks for javac
dnl ===================================================================
if test "$ENABLE_JAVA" != ""; then
javacompiler="javac"
- JAVA_SOURCE_VER="1.6"
- JAVA_TARGET_VER="1.6"
+ : ${JAVA_SOURCE_VER=1.6}
+ : ${JAVA_TARGET_VER=1.6}
if test -z "$with_jdk_home"; then
AC_PATH_PROG(JAVACOMPILER, $javacompiler)
else