summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-04-04 15:05:44 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-04-07 14:54:40 +0200
commitc51b68ddd9381b6b2ddfd8ab03c8420914a95d55 (patch)
tree63ece3925abf15aa27119222e758fcab240b6476 /configure.ac
parentOString has a std::hash specialisation (diff)
downloadcore-c51b68ddd9381b6b2ddfd8ab03c8420914a95d55.tar.gz
core-c51b68ddd9381b6b2ddfd8ab03c8420914a95d55.zip
clang version in configure output without spaces
Call me pedantic. Change-Id: I96b8b7ef511508da0df75589475eaf13d639a7c9 Reviewed-on: https://gerrit.libreoffice.org/70365 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index befe75bbac3a..457511f063c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3636,7 +3636,7 @@ if test "$COM_IS_CLANG" = TRUE; then
else
my_args="-E -P"
fi
- clang_version=`echo __clang_major__.__clang_minor__.__clang_patchlevel__ | $CC_PLAIN $my_args -`
+ clang_version=`echo __clang_major__.__clang_minor__.__clang_patchlevel__ | $CC_PLAIN $my_args - | sed 's/ //g'`
CLANGVER=`echo $clang_version \
| $AWK -F. '{ print \$1*10000+(\$2<100?\$2:99)*100+(\$3<100?\$3:99) }'`
if test "$CLANGVER" -ge 50002; then