summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-05-01 19:57:39 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-05-09 11:02:52 +0200
commit7f992595a4f4bed38f67c2fa34ffafecb082753a (patch)
treed83b8dcba1460282363e06bd5b2bc7055a8814ff /configure.ac
parentuse .gch only for gcc's PCH files (diff)
downloadcore-7f992595a4f4bed38f67c2fa34ffafecb082753a.tar.gz
core-7f992595a4f4bed38f67c2fa34ffafecb082753a.zip
simply set ccache env.vars instead of just warning about them
So that it works out of the box automagically. Change-Id: I0a6c93824233eef6ce25c44762ec40770ec5110f Reviewed-on: https://gerrit.libreoffice.org/71628 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 8ed51262b391..6a7e7b4734d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5075,18 +5075,6 @@ elif test "$enable_pch" = "no"; then
else
AC_MSG_ERROR([Unknown value for --enable-pch])
fi
-if test -n "$ENABLE_PCH"; then
- if test -n "$CCACHE"; then
- if ! echo "$CCACHE_SLOPPINESS" | grep -q pch_defines | grep -q time_macros; then
- AC_MSG_WARN([PCH with ccache requires CCACHE_SLOPPINESS to include 'pch_defines,time_macros'])
- add_warning "PCH with ccache requires CCACHE_SLOPPINESS to include 'pch_defines,time_macros'"
- fi
- if test -z "$CCACHE_PCH_EXTSUM"; then
- AC_MSG_WARN([It is recommended to set CCACHE_PCH_EXTSUM=1 for PCH with ccache.])
- add_warning "It is recommended to set CCACHE_PCH_EXTSUM=1 for PCH with ccache."
- fi
- fi
-fi
AC_SUBST(ENABLE_PCH)
TAB=`printf '\t'`