summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Udvare <audvare@gmail.com>2019-01-08 04:53:51 -0500
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2019-02-10 07:56:14 +0100
commit6776c53b7ce2e431d8636f4e5a755f50f787ec8f (patch)
tree7b44ae5238a3cdaa9e1e6a7eb95d46aa27f9a96b /configure.ac
parentKJ & elementary: Add missing format text in Draw, elementary: update shape ma... (diff)
downloadcore-6776c53b7ce2e431d8636f4e5a755f50f787ec8f.tar.gz
core-6776c53b7ce2e431d8636f4e5a755f50f787ec8f.zip
Make LDAP support optional
Change-Id: Ifbd3903494a81e7b155bf6468f6ca2c50b3370a4 Reviewed-on: https://gerrit.libreoffice.org/65958 Tested-by: Jenkins Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f880308285b8..35c7e02d36d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1519,6 +1519,11 @@ libo_FUZZ_ARG_ENABLE(formula-logger,
)
)
+AC_ARG_ENABLE(ldap,
+ AS_HELP_STRING([--disable-ldap],
+ [Disable LDAP support.]),
+,enable_ldap=yes)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -9214,12 +9219,29 @@ else
fi
AC_SUBST(SYSTEM_ODBC_HEADERS)
+dnl ===================================================================
+dnl Enable LDAP support in Base
+dnl ===================================================================
+
+if test "$_os" != "WINNT" -a "$_os" != "iOS" -a "$_os" != "Android"; then
+AC_MSG_CHECKING([whether to enable LDAP support])
+ if test "$enable_ldap" != "yes"; then
+ AC_MSG_RESULT([no])
+ ENABLE_LDAP=""
+ enable_ldap=no
+ else
+ AC_MSG_RESULT([yes])
+ ENABLE_LDAP="TRUE"
+ AC_DEFINE(HAVE_FEATURE_LDAP)
+ fi
+fi
+AC_SUBST(ENABLE_LDAP)
dnl ===================================================================
dnl Check for system openldap
dnl ===================================================================
-if test "$_os" != "WINNT" -a "$_os" != "iOS" -a "$_os" != "Android"; then
+if test "$_os" != "WINNT" -a "$_os" != "iOS" -a "$_os" != "Android" -a "$ENABLE_LDAP" != ""; then
AC_MSG_CHECKING([which openldap library to use])
if test "$with_system_openldap" = "yes"; then
AC_MSG_RESULT([external])