summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-12-06 16:36:01 +0100
committerThorsten Behrens <thorsten.behrens@allotropia.de>2021-04-09 23:22:01 +0200
commit6572dbc2fa36fb9189bd1ed21748e73a88418e15 (patch)
tree6d222150affeba0b7ec98f4b3479f06801c0a96d /configure.ac
parentAdd --with-latest-c++ to explicitly opt in for -std=c++20/-std:c++latest (diff)
downloadcore-6572dbc2fa36fb9189bd1ed21748e73a88418e15.tar.gz
core-6572dbc2fa36fb9189bd1ed21748e73a88418e15.zip
Adapt o3tl::span to P1872R0
..."span should have size_type, not index_type" (<http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1872r0.pdf>), as implemented by libc++ since <https://github.com/llvm/llvm-project/commit/ 1466335cf4b2854a0be1defcf279fe50772bad6f> "[libc++][P1872] span should have size_type, not index_type." All uses of index_type had been added to mitigate the previous std::span change from signed (ptrdiff_t) to unsigned (size_t) index_type, see 6ef8420fdbf8dff16de13147c5ab833bc5e01121 "Adapt o3tl::span to updated C++2a std::span". There is no easy solution to transparently support all three std::span variants currently out there (signed index_type, unsigned index_type, unsigned size_type), without causing compilation failures due to CPPUNIT_ASSERT_EQUAL with arguments of different types, or compiler warnings about mixed signed/unsigned comparisons. So rule out the oldest std::span variant (signed index_type) in configure.ac (so that o3tl::span will use its own hand-rolled code in that case) and simplify the uses of index_type to std::size_t (as had already been mentioned in 6ef8420fdbf8dff16de13147c5ab833bc5e01121). Reviewed-on: https://gerrit.libreoffice.org/84652 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> (cherry picked from commit 8e6865188242bccb3d8aa857ddc990d72a058d3d) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/87757 Reviewed-by: Caolán McNamara <caolanm@redhat.com> (cherry picked from commit bb9833594b031c6d0ec91422f85968c4b1f2f8bc) Change-Id: I6ddf424ffb7941da3f69ad66fd29ecd35f09afae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b33e5f0bc0a..0e61b295b66f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6766,6 +6766,22 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])
+AC_MSG_CHECKING([whether $CXX supports C++2a <span> with unsigned size_type])
+AC_LANG_PUSH([C++])
+save_CXXFLAGS=$CXXFLAGS
+CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <span>
+ #include <type_traits>
+ // Don't check size_type directly, as it was called index_type before P1872R0:
+ void f(std::span<int> s) { static_assert(std::is_unsigned_v<decltype(s.size())>); };
+ ])], [
+ AC_DEFINE([HAVE_CPP_SPAN],[1])
+ AC_MSG_RESULT([yes])
+ ], [AC_MSG_RESULT([no])])
+CXXFLAGS=$save_CXXFLAGS
+AC_LANG_POP([C++])
+
AC_MSG_CHECKING([whether $CXX has GCC bug 87150])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS