summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2019-06-10 20:11:48 +0100
committerCaolán McNamara <caolanm@redhat.com>2019-06-12 10:01:52 +0200
commit582f45bb9a80300158f73254d66f661b196b3732 (patch)
tree2604e2334c14414f5a17efefa4c1a4f9458c8d13 /configure.ac
parentResolves: tdf#125808 empty labels in pivot table from registered data source (diff)
downloadcore-582f45bb9a80300158f73254d66f661b196b3732.tar.gz
core-582f45bb9a80300158f73254d66f661b196b3732.zip
Related: rhbz#1718063 look for pkg-config python-version-embed
Change-Id: I7048171501e32d29f9d5a58f0d5fc0b96b318a4e Reviewed-on: https://gerrit.libreoffice.org/73809 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77cbacb109b6..39dd082b8366 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8574,6 +8574,9 @@ if test $enable_python = system; then
if test -z "$PKG_CONFIG"; then
PYTHON_CFLAGS="-I$python_include"
PYTHON_LIBS="-L$python_libdir -lpython$python_version $python_libs"
+ elif $PKG_CONFIG --exists python-$python_version-embed; then
+ PYTHON_CFLAGS="`$PKG_CONFIG --cflags python-$python_version-embed`"
+ PYTHON_LIBS="`$PKG_CONFIG --libs python-$python_version-embed` $python_libs"
elif $PKG_CONFIG --exists python-$python_version; then
PYTHON_CFLAGS="`$PKG_CONFIG --cflags python-$python_version`"
PYTHON_LIBS="`$PKG_CONFIG --libs python-$python_version` $python_libs"