summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-02-14 01:37:10 +0100
committerNoel Grandin <noel.grandin@collabora.co.uk>2020-02-15 17:53:18 +0100
commit1896b9cf0011b0f2f453d8123141ab24957b8947 (patch)
tree7fdeae6e36c15d7a5a2a52d9b71e6d2f6b9fd00f /configure.ac
parenttdf#126700 allow replacing the default documents (diff)
downloadcore-1896b9cf0011b0f2f453d8123141ab24957b8947.tar.gz
core-1896b9cf0011b0f2f453d8123141ab24957b8947.zip
tdf#122218: Hack to avoid blurry text with macOS SDK 10.15
...by setting the LC_VERSION_MIN_MACOSX load command's sdk value to n/a in the soffice executable. See <https://bugs.documentfoundation.org/show_bug.cgi?id=122218#c167> for how this helps, even though I have no idea why it helps. (Adding that -platform_version linker option appears to generate warnings like > ld: warning: passed two min versions (10.13.0, 10.13) for platform macOS. Using 10.13. but which are probably harmless.) (cherry picked from commit 645fe53be0dc36535dba0ed684e21ca4cda80d70) Plus cherry-pick of follow-up b7fd89100d8653dc73955780358fe31d38b68ebf "tdf#122218: Baseline Xcode 9.3 ld presumably doesn't support -platform_version" (and resolving the merge conflict in desktop/Executable_soffice_bin.mk). cherry picked from libreoffice-6-4 <https://gerrit.libreoffice.org/c/core/+/88753> Conflicts: configure.ac Change-Id: I043498c7ff2d148d4a7e1e0e9d46241b638f2eba Reviewed-on: https://gerrit.libreoffice.org/c/core/+/88667 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/88755 Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c62f88352543..32b4041a29f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2724,6 +2724,7 @@ dnl ===================================================================
dnl Check macOS SDK and compiler
dnl ===================================================================
+HAVE_MACOS_LD_PLATFORMVERSION=
if test $_os = Darwin -o $_os = iOS; then
# If no --with-macosx-sdk option is given, look for one
@@ -2962,6 +2963,16 @@ if test $_os = Darwin -o $_os = iOS; then
AC_MSG_CHECKING([what macOS app bundle identifier to use])
MACOSX_BUNDLE_IDENTIFIER=$with_macosx_bundle_identifier
AC_MSG_RESULT([$MACOSX_BUNDLE_IDENTIFIER])
+
+ AC_MSG_CHECKING([whether the linker supports -platform_version])
+ save_LDFLAGS=$LDFLAGS
+ LDFLAGS="$LDFLAGS -Xlinker -platform_version -Xlinker macos \
+ -Xlinker $MAC_OS_X_VERSION_MIN_REQUIRED_DOTS -Xlinker 0.0.0"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM()],
+ [AC_MSG_RESULT([yes])
+ HAVE_MACOS_LD_PLATFORMVERSION=TRUE],
+ [AC_MSG_RESULT([no])])
+ LDFLAGS=$save_LDFLAGS
fi
AC_SUBST(MACOSX_SDK_PATH)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
@@ -2974,6 +2985,7 @@ AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(MACOSX_PACKAGE_SIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_SUBST(HAVE_MACOS_LD_PLATFORMVERSION)
dnl ===================================================================
dnl Check iOS SDK and compiler