summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAshod Nakashian <ashod.nakashian@collabora.co.uk>2019-03-06 22:06:35 -0500
committerAndras Timar <andras.timar@collabora.com>2019-03-07 11:43:25 +0100
commit0d8c670797f6becc584cf2eca4f414df7a3d0d85 (patch)
treea197ba053e698bc398b16509b2bddc726770c276 /configure.ac
parentUpdate git submodules (diff)
downloadcore-0d8c670797f6becc584cf2eca4f414df7a3d0d85.tar.gz
core-0d8c670797f6becc584cf2eca4f414df7a3d0d85.zip
build: support disabling poppler
This adds --enable-poppler configure option. Poppler can be enabled/disabled by setting this parameter to yes or no. Change-Id: I42ba2d27de7b5014d28523394310616d20073b71 Reviewed-on: https://gerrit.libreoffice.org/68602 Reviewed-by: Andras Timar <andras.timar@collabora.com> Tested-by: Andras Timar <andras.timar@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/68842 Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 36 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index c4d789140362..974eab39c7ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1725,6 +1725,11 @@ AC_ARG_WITH(system-openldap,
[Use the OpenLDAP LDAP SDK already on system.]),,
[with_system_openldap="$with_system_libs"])
+libo_FUZZ_ARG_ENABLE(poppler,
+ AS_HELP_STRING([--disable-poppler],
+ [Disable building Poppler.])
+)
+
AC_ARG_WITH(system-poppler,
AS_HELP_STRING([--with-system-poppler],
[Use system poppler (only needed for PDF import).]),,
@@ -10644,6 +10649,33 @@ AC_SUBST([DCONF_CFLAGS])
AC_SUBST([DCONF_LIBS])
AC_SUBST([ENABLE_DCONF])
+# Pdfium?
+AC_MSG_CHECKING([whether to build PDFium])
+ENABLE_PDFIUM=
+if test -z "$enable_pdfium" -o "$enable_pdfium" = yes; then
+ AC_MSG_RESULT([yes])
+ ENABLE_PDFIUM=TRUE
+ AC_DEFINE(HAVE_FEATURE_PDFIUM)
+ BUILD_TYPE="$BUILD_TYPE PDFIUM"
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_PDFIUM)
+
+dnl ===================================================================
+dnl Check for poppler
+dnl ===================================================================
+ENABLE_POPPLER=
+AC_MSG_CHECKING([enable poppler])
+if test -z "$enable_poppler" -o "$enable_poppler" = yes; then
+ AC_MSG_RESULT([yes])
+ ENABLE_POPPLER=TRUE
+ AC_DEFINE(HAVE_FEATURE_POPPLER)
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_POPPLER)
+
# pdf import?
AC_MSG_CHECKING([whether to build the PDF import feature])
ENABLE_PDFIMPORT=
@@ -10651,7 +10683,11 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
AC_MSG_RESULT([yes])
ENABLE_PDFIMPORT=TRUE
AC_DEFINE(HAVE_FEATURE_PDFIMPORT)
+else
+ AC_MSG_RESULT([no])
+fi
+if test $ENABLE_PDFIMPORT == TRUE -a $ENABLE_POPPLER == TRUE; then
dnl ===================================================================
dnl Check for system poppler
dnl ===================================================================
@@ -10682,27 +10718,12 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
AC_DEFINE([HAVE_POPPLER_VERSION_H], 1)
fi
AC_DEFINE([ENABLE_PDFIMPORT],1)
-else
- AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_PDFIMPORT)
AC_SUBST(SYSTEM_POPPLER)
AC_SUBST(POPPLER_CFLAGS)
AC_SUBST(POPPLER_LIBS)
-# pdf import?
-AC_MSG_CHECKING([whether to build PDFium])
-ENABLE_PDFIUM=
-if test -z "$enable_pdfium" -o "$enable_pdfium" = yes; then
- AC_MSG_RESULT([yes])
- ENABLE_PDFIUM=TRUE
- AC_DEFINE(HAVE_FEATURE_PDFIUM)
- BUILD_TYPE="$BUILD_TYPE PDFIUM"
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ENABLE_PDFIUM)
-
SYSTEM_GPGMEPP=
if test "$build_for_ios" = "YES"; then