summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2013-03-28 13:37:37 +0100
committerLuboš Luňák <l.lunak@suse.cz>2013-03-28 13:37:37 +0100
commit86461bd2862d22eaaef97e110ba3fee996e88164 (patch)
tree8e07d26a91183db52fd20ffdb23af38ca851e894 /configure.ac
parentRelated rhbz#928568: Detect aggregators listening at themselves (diff)
downloadcore-86461bd2862d22eaaef97e110ba3fee996e88164.tar.gz
core-86461bd2862d22eaaef97e110ba3fee996e88164.zip
revert the --enable-clang option
This should be completely equivalent to ./autogen.sh CC=clang CXX=clang++ , which is the normal way to pass any compiler to configure, so this is needless duplication. This reverts commits 1a843cc54dd6a08fa5fccb4314c025d432e46ad1 and 02ed2608199f2adc466849d0f4864213ad07c445 . Change-Id: Ib02ab84a7b84fe4797dca0f62aa5049c1be55302
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 31 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index 998d9b0c560d..7ef0db621a23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1158,11 +1158,6 @@ AC_ARG_ENABLE(winegcc,
needed for MinGW cross-compilation.]),
)
-AC_ARG_ENABLE(clang,
- AS_HELP_STRING([--enable-clang],
- [Build using the clang compiler.]),
-)
-
AC_ARG_ENABLE(liblangtag,
AS_HELP_STRING([--disable-liblangtag],
[Disable use of liblangtag, and insted use an own simple
@@ -2277,36 +2272,43 @@ if test "$CCACHE" != ""; then
fi
dnl ===================================================================
-dnl Checks for Icecream
-dnl ===================================================================
-if test "$enable_icecream" = "yes"; then
- if test -d "/usr/lib/icecc/bin"; then
- ICECREAM_HOME="/usr/lib/icecc"
- else
- ICECREAM_HOME="/opt/icecream"
- fi
- if test -z "$CC"; then
- CC="$ICECREAM_HOME/bin/gcc"
- fi
- if test -z "$CXX"; then
- CXX="$ICECREAM_HOME/bin/g++"
- fi
-fi
-
-dnl ===================================================================
dnl Checks for C compiler,
-dnl AC_PROG_CC checks for gcc, cc and then cl (if it weren't guarded for win32)
dnl The check for the C++ compiler is later on.
dnl ===================================================================
+if test "$_os" != "WINNT" -a "$WITH_MINGW" != "yes"; then
+ GCC_HOME_SET="true"
+ AC_MSG_CHECKING([gcc home])
+ if test -z "$with_gcc_home"; then
+ if test "$enable_icecream" = "yes"; then
+ if test -d "/usr/lib/icecc/bin"; then
+ GCC_HOME="/usr/lib/icecc/"
+ else
+ GCC_HOME="/opt/icecream/"
+ fi
+ else
+ GCC_HOME=`which gcc | $SED -e s,/bin/gcc,,`
+ GCC_HOME_SET="false"
+ fi
+ else
+ GCC_HOME="$with_gcc_home"
+ fi
+ AC_MSG_RESULT($GCC_HOME)
+ AC_SUBST(GCC_HOME)
+
+ if test "$GCC_HOME_SET" = "true"; then
+ if test -z "$CC"; then
+ CC="$GCC_HOME/bin/gcc"
+ fi
+ if test -z "$CXX"; then
+ CXX="$GCC_HOME/bin/g++"
+ fi
+ fi
+fi
+
+dnl The following checks for gcc, cc and then cl (if it weren't guarded for win32)
if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
# AC_PROG_CC sets CFLAGS to -g -O2 if not set, avoid that
save_CFLAGS=$CFLAGS
- if test "$enable_clang" = "yes"; then
- AC_PATH_PROG(CC,clang)
- if test -z "$CC"; then
- AC_MSG_ERROR([Clang not found in path. Is it installed?])
- fi
- fi
AC_PROG_CC
CFLAGS=$save_CFLAGS
fi
@@ -4998,12 +5000,6 @@ dnl ===================================================================
if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
# AC_PROG_CXX sets CXXFLAGS to -g -O2 if not set, avoid that
save_CXXFLAGS=$CXXFLAGS
- if test "$enable_clang" = "yes"; then
- AC_PATH_PROG(CXX,clang++)
- if test -z "$CXX"; then
- AC_MSG_ERROR([clang++ not found in path. Is it installed?])
- fi
- fi
AC_PROG_CXX
CXXFLAGS=$save_CXXFLAGS
else