summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-09-19 09:44:38 +0200
committerjan Iversen <jani@libreoffice.org>2017-09-19 14:02:51 +0200
commit7e1489bb4c2d11380d28cea2c3cf5d76303eecae (patch)
treee708e5d6f6a8cf6e9d2de88fcc0ea8a58f0d4d36 /configure.ac
parentofz: survive missing config (diff)
downloadcore-7e1489bb4c2d11380d28cea2c3cf5d76303eecae.tar.gz
core-7e1489bb4c2d11380d28cea2c3cf5d76303eecae.zip
iOS, remove support for 32bit (arm).
Supporting 32bit iOS, means a.o. adding several libraries to the dependency list because macOSX does not install them by default (e.g. zlib). 32bit is only used in old iPhones. updated configure.ac removed from solenv/gbuild/platform bridges corrected Change-Id: I415e744a9cb4acb3b5fbfca33c22940a1d56e390
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 6 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index b4932349a165..08a30cdd0352 100644
--- a/configure.ac
+++ b/configure.ac
@@ -620,7 +620,7 @@ darwin*) # Mac OS X or iOS
test_freetype=no
test_fontconfig=no
test_dbus=no
- if test "$host_cpu" = "arm" -o "$host_cpu" = "arm64"; then
+ if test "$host_cpu" = "arm64"; then
_os=iOS
test_gtk=no
test_cups=no
@@ -2391,8 +2391,9 @@ if test -z "$enable_database_connectivity"; then
# --disable-database-connectivity is unfinished work in progress
# and the iOS test app doesn't link if we actually try to use it.
# if test $_os != iOS -a $_os != Android; then
+ if test $_os != iOS; then
enable_database_connectivity=yes
- # fi
+ fi
fi
if test "$enable_database_connectivity" = yes; then
@@ -3066,7 +3067,7 @@ if test "$_os" = "WINNT"; then
fi
fi
if test "$_os" = "iOS"; then
- if test "$host_cpu" = "arm" -o "$host_cpu" = "arm64" ; then
+ if test "$host_cpu" = "arm64" ; then
cross_compiling="yes"
fi
fi
@@ -3936,16 +3937,7 @@ darwin*)
case "$host_cpu" in
arm)
- OS=IOS
- if test "$enable_ios_simulator" = "yes"; then
- CPUNAME=I386
- RTL_ARCH=x86
- PLATFORMID=macosx_x86
- else
- RTL_ARCH=ARM_EABI
- CPUNAME=ARM
- PLATFORMID=ios_arm
- fi
+ AC_MSG_ERROR([Can't build 32-bit code for iOS])
;;
arm64)
OS=IOS
@@ -5577,14 +5569,7 @@ dnl ===================================================================
if test "$_os" != "WINNT"; then
if test "$_os" == "iOS"; then
-if test "$host_cpu" == "arm"; then
- ac_cv_sizeof_long=4
- ac_cv_sizeof_short=2
- ac_cv_sizeof_int=4
- ac_cv_sizeof_long_long=8
- ac_cv_sizeof_double=8
- ac_cv_sizeof_voidp=4
-else
+if test "$host_cpu" == "arm64"; then
ac_cv_sizeof_long=8
ac_cv_sizeof_short=2
ac_cv_sizeof_int=4