summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-09-12 23:14:41 +0300
committerTor Lillqvist <tml@collabora.com>2013-09-13 19:57:58 +0300
commitd042e96658efb9c842681aa5dc769acbbafd11b8 (patch)
treef7a1ffcf03f77313158ef1cc9f0dcd37bbec31ea /configure.ac
parentIf we have strlcat(), we have strlcat(), no need to declare it (diff)
downloadcore-d042e96658efb9c842681aa5dc769acbbafd11b8.tar.gz
core-d042e96658efb9c842681aa5dc769acbbafd11b8.zip
For fun, handle --enable-64-bit for iOS, too
Change-Id: I745d51c5b8f4296c00ae1b652b42a311d89a0ed9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 18 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0521e27cce06..a12823ac97f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2833,6 +2833,12 @@ dnl ===================================================================
if test $_os = iOS; then
+ if test "$enable_64_bit" = "" -o "$enable_64_bit" = "no"; then
+ :
+ else
+ BITNESS_OVERRIDE=64
+ fi
+
AC_MSG_CHECKING([what iOS SDK to use])
xcode_developer=`xcode-select -print-path`
@@ -2840,11 +2846,20 @@ if test $_os = iOS; then
if test "$enable_ios_simulator" = yes; then
platform=iPhoneSimulator
versionmin=-mmacosx-version-min=10.7
- arch=i386
+ if test "$BITNESS_OVERRIDE" = 64; then
+ arch=x86_64
+ else
+ arch=i386
+ fi
else
platform=iPhoneOS
- versionmin=-miphoneos-version-min=5.0
- arch=armv7
+ if test "$BITNESS_OVERRIDE" = 64; then
+ arch=arm64
+ versionmin=-miphoneos-version-min=7.0
+ else
+ arch=armv7
+ versionmin=-miphoneos-version-min=5.0
+ fi
fi
pref_sdk_ver=6.1