summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKohei Yoshida <kohei.yoshida@collabora.com>2013-09-11 14:45:36 -0400
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2013-09-19 17:03:16 +0200
commitf1717208ec22f146acec5ad2483c5cdc9a536484 (patch)
tree9234dade5fee227f8eceee4fb7a87708a186c672 /configure.ac
parentUse clew from clcc to allow run-time loading of opencl drivers. (diff)
downloadcore-f1717208ec22f146acec5ad2483c5cdc9a536484.tar.gz
core-f1717208ec22f146acec5ad2483c5cdc9a536484.zip
Remove opencl-sdk configure option, and build time opencl conditionals.
We now load OpenCL library dynmically at run-time as needed. So there is no build time dependency on any OpenCL implementations. Change-Id: I214399060398a7c5e37b9a254147ccc2834e7866
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 0 insertions, 48 deletions
diff --git a/configure.ac b/configure.ac
index 75a402e2f6ec..501e56d9ae0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1810,16 +1810,6 @@ AC_ARG_WITH(windows-sdk,
],
,)
-AC_ARG_WITH(opencl-sdk,
- AS_HELP_STRING([--with-opencl-sdk],
- [If you have the AMD HSA / opencl SDK installed (cf.
- http://developer.amd.com/tools-and-sdks/heterogeneous-computing/amd-accelerated-parallel-processing-app-sdk/downloads/ )
- Pass the absolute path to where that SDK is unpacked.])
- [
- Usage: --with-opencl-sdk=/opt/AMDAPP
- ],
-,)
-
AC_ARG_WITH(lang,
AS_HELP_STRING([--with-lang],
[Use this option to build LibreOffice with additional language support.
@@ -10232,44 +10222,6 @@ fi
AC_SUBST(SYSTEM_MESA_HEADERS)
AC_SUBST(ENABLE_OPENGL)
-dnl =================================================
-dnl Check whether the OpenCL libraries are available
-dnl =================================================
-
-OPENCL_LIBS=
-OPENCL_CFLAGS=
-ENABLE_OPENCL=
-AC_MSG_CHECKING([OpenCL])
-if test \( -z "$with_opencl_sdk" -o "$with_opencl_sdk" = yes \) -a $_os = Darwin -a "$with_macosx_sdk" != 10.6; then
- # OS X SDK > 10.6
- AC_MSG_RESULT([yes, always on OS X > 10.6])
- ENABLE_OPENCL=TRUE
- OPENCL_CFLAGS=
- OPENCL_LIBS="-framework OpenCL"
- AC_DEFINE(HAVE_FEATURE_OPENCL)
-elif test -z "$with_opencl_sdk" -o "$with_opencl_sdk" = no; then
- AC_MSG_RESULT([no])
-else
- if test -d "$with_opencl_sdk/include"; then
- ENABLE_OPENCL=TRUE
- if test "$_os" = "WINNT"; then
- PathFormat "$with_opencl_sdk"
- OPENCL_CFLAGS="-I$formatted_path/include"
- OPENCL_LIBS="-LIBPATH:$formatted_path/lib/x86 OpenCL.lib"
- else
- OPENCL_CFLAGS="-I$with_opencl_sdk/include"
- OPENCL_LIBS="-L$with_opencl_sdk/lib/x86 -lOpenCL"
- fi
- AC_MSG_RESULT([found at path $with_opencl_sdk])
- AC_DEFINE(HAVE_FEATURE_OPENCL)
- else
- AC_MSG_ERROR([no headers found found at $with_opencl_sdk/include ])
- fi
-fi
-AC_SUBST(OPENCL_CFLAGS)
-AC_SUBST(OPENCL_LIBS)
-AC_SUBST(ENABLE_OPENCL)
-
# presenter minimizer extension?
AC_MSG_CHECKING([whether to build the Presentation Minimizer extension])
if test "x$enable_ext_presenter_minimizer" != "xno" -a "x$enable_extension_integration" != "xno"; then