summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2019-06-05 02:06:00 +0300
committerTor Lillqvist <tml@collabora.com>2019-10-31 07:53:15 +0100
commite93e0fb7ac8f14230434653e5d5f318707712667 (patch)
tree5f81d2f79abb2517012f2537c6d44df0ef7ad0f7 /configure.ac
parent-[NSWindow setRestorable:] is present since 10.7 (diff)
downloadcore-e93e0fb7ac8f14230434653e5d5f318707712667.tar.gz
core-e93e0fb7ac8f14230434653e5d5f318707712667.zip
The Bluetooth code doesn't compile with macOS SDK 10.15
Change-Id: I8fffa4cef9628e6872c881cd0cbdfe85495fa324 (cherry picked from commit 1e95c8dd006147f7a94e24135396277ee2f469b8) Reviewed-on: https://gerrit.libreoffice.org/81772 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b9fb4765932a..f04351f6cc41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10493,6 +10493,10 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
ENABLE_SDREMOTE=TRUE
AC_MSG_CHECKING([whether to enable Bluetooth support in Impress remote control])
+ if test $OS = MACOSX -a "$MAC_OS_X_VERSION_MAX_ALLOWED" -ge 101500; then
+ # The Bluetooth code doesn't compile with macOS SDK 10.15
+ enable_sdremote_bluetooth=no
+ fi
# If not explicitly enabled or disabled, default
if test -z "$enable_sdremote_bluetooth"; then
case "$OS" in