summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-08-30 12:54:37 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2013-08-30 19:59:02 +0000
commitd5d721a130df631f1cf46ac636ba22314f539f6b (patch)
tree9a988af44fd2cbfe90be3d531471215b2ae28a34 /configure.ac
parentENABLE_BLUETOOTH* Harmonize ENABLE_* variable to TRUE/<nothing> (diff)
downloadcore-d5d721a130df631f1cf46ac636ba22314f539f6b.tar.gz
core-d5d721a130df631f1cf46ac636ba22314f539f6b.zip
ENABLE_SCRIPTING_* Harmonize ENABLE_* variable to TRUE/<nothing>
Change-Id: I937967889da75062c792cf377ce4e13c67526162 Reviewed-on: https://gerrit.libreoffice.org/5702 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c22e29699b6c..be7ddd7f2b00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10589,7 +10589,7 @@ AC_SUBST(COMMONS_LOGGING_JAR)
AC_MSG_CHECKING([whether to build support for scripts in BeanShell])
if test "${enable_scripting_beanshell}" != "no" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([yes])
- ENABLE_SCRIPTING_BEANSHELL=YES
+ ENABLE_SCRIPTING_BEANSHELL=TRUE
dnl ===================================================================
dnl Check for system beanshell
@@ -10610,7 +10610,7 @@ if test "${enable_scripting_beanshell}" != "no" -a "x$with_java" != "xno"; then
fi
else
AC_MSG_RESULT([no])
- ENABLE_SCRIPTING_BEANSHELL=NO
+ ENABLE_SCRIPTING_BEANSHELL=
SCPDEFS="$SCPDEFS -DWITHOUT_SCRIPTING_BEANSHELL"
fi
AC_SUBST(ENABLE_SCRIPTING_BEANSHELL)
@@ -10621,7 +10621,7 @@ AC_SUBST(BSH_JAR)
AC_MSG_CHECKING([whether to build support for scripts in JavaScript])
if test "${enable_scripting_javascript}" != "no" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([yes])
- ENABLE_SCRIPTING_JAVASCRIPT=YES
+ ENABLE_SCRIPTING_JAVASCRIPT=TRUE
dnl ===================================================================
dnl Check for system rhino
@@ -10642,7 +10642,7 @@ if test "${enable_scripting_javascript}" != "no" -a "x$with_java" != "xno"; then
fi
else
AC_MSG_RESULT([no])
- ENABLE_SCRIPTING_JAVASCRIPT=NO
+ ENABLE_SCRIPTING_JAVASCRIPT=
SCPDEFS="$SCPDEFS -DWITHOUT_SCRIPTING_JAVASCRIPT"
fi
AC_SUBST(ENABLE_SCRIPTING_JAVASCRIPT)