summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-09-30 22:32:58 +0300
committerTor Lillqvist <tml@collabora.com>2013-09-30 22:33:45 +0300
commitaa6eee03c6082a7882a35d6e3c822e7473eec6f7 (patch)
treea241247d385f832a780f6aee8caa86a1952f4654 /configure.ac
parentCheck separately and more thoroughly what the C++ library is (diff)
downloadcore-aa6eee03c6082a7882a35d6e3c822e7473eec6f7.tar.gz
core-aa6eee03c6082a7882a35d6e3c822e7473eec6f7.zip
Simiplify test
Change-Id: I8ab1842ef1eb6f2988a547f0837daa81bbaff595
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7da4edfb1af8..8cb15d74475a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6360,9 +6360,9 @@ if test \( "$_os" != "WINNT" -o "$WITH_MINGW" = "yes" \); then
CPPFLAGS="-isysroot $MACOSX_SDK_PATH $CPPFLAGS"
fi
- # Assume visibility is not broken with libc++ even if libc++ headers. The below test is very much
- # designed for libstdc++ only.
- if test "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE" -a \( "$COM_GCC_IS_CLANG" != TRUE -o "$CPP_LIBRARY" != LIBCPP \); then
+ # Assume visibility is not broken with libc++. The below test is very much designed for libstdc++
+ # only.
+ if test "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE" -a "$CPP_LIBRARY" = GLIBCXX; then
dnl gcc#19664, gcc#22482, rhbz#162935
AC_MSG_CHECKING([if STL headers are visibility safe (GCC bug 22482)])
AC_EGREP_HEADER(visibility push, string, stlvisok=yes, stlvisok=no)