summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-12-05 21:40:04 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-12-06 07:26:31 +0100
commit90d2155912bcee40377620d4836726041a72d537 (patch)
tree4a83922ab7dd3a15bfccf0ad48ffd41651785742 /configure.ac
parentRemove CXXFLAGS_CXX11 from Clang plugin compilation (diff)
downloadcore-90d2155912bcee40377620d4836726041a72d537.tar.gz
core-90d2155912bcee40377620d4836726041a72d537.zip
Work around latest Boost 1.65.1 still using deprecated std::auto_ptr
...in various places, which is gone by default at least from recent libc++ in C++17 mode. So bring it back there for now, until Boost is fixed. Change-Id: I0b3128d114ab2b5693a84bdc7d2b9b9b9b5c3c76 Reviewed-on: https://gerrit.libreoffice.org/45910 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 208debcbe5a0..e8d1f6a9bfa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5947,6 +5947,7 @@ foo bar
]])],
[CPP_LIBRARY=LIBCPP
cpp_library_name="LLVM libc++"
+ AC_DEFINE([HAVE_LIBCXX])
],
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <utility>
@@ -12487,6 +12488,7 @@ AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_gpgme.h])
AC_CONFIG_HEADERS([config_host/config_java.h])
AC_CONFIG_HEADERS([config_host/config_lgpl.h])
+AC_CONFIG_HEADERS([config_host/config_libcxx.h])
AC_CONFIG_HEADERS([config_host/config_libepubgen.h])
AC_CONFIG_HEADERS([config_host/config_liblangtag.h])
AC_CONFIG_HEADERS([config_host/config_locales.h])