summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-08-13 10:39:00 +0200
committerMiklos Vajna <vmiklos@collabora.com>2019-08-14 09:30:12 +0200
commit80805539f6bd9b5f6229682aa187de705cb83de9 (patch)
tree8050a10b0573ea84ab111792d229a64fbc1f5a85 /configure.ac
parenttdf#126684: store "DialogUseCharAttr" in RES_PARATR_GRABBAG (diff)
downloadcore-80805539f6bd9b5f6229682aa187de705cb83de9.tar.gz
core-80805539f6bd9b5f6229682aa187de705cb83de9.zip
configure: don't enable export validation if there are no schemas
Schemas are excluded from tarballs since commit 34dced99c33a97dab86c4538fa267ad4ad4fb41f because of the license. Change-Id: I6540926d9ebb390d7956bbd1df3bb915adebb64b Reviewed-on: https://gerrit.libreoffice.org/77383 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> (cherry picked from commit c78dd0a726b32d922a0d75a26a51d4c30612368c) Reviewed-on: https://gerrit.libreoffice.org/77392 Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3508907a0c3b..bc309b8037e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7620,6 +7620,12 @@ if test "$with_export_validation" != "no"; then
else
AC_MSG_RESULT([no, as Java is too old, need Java 8])
fi
+ elif ! test -d "${SRC_ROOT}/schema"; then
+ if test "$with_export_validation" = "yes"; then
+ AC_MSG_ERROR([requested, but schema directory is missing (it is excluded from tarballs)])
+ else
+ AC_MSG_RESULT([no, schema directory is missing (it is excluded from tarballs)])
+ fi
else
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_EXPORT_VALIDATION)