summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2018-08-02 15:13:37 +0100
committerCaolán McNamara <caolanm@redhat.com>2018-08-04 15:37:30 +0200
commit6ddecf61ecada646fbd6f8809270d47289727e8a (patch)
treed4d699b1a811e751e6bb948e441c4cdd822cb708 /configure.ac
parentUpdate git submodules (diff)
downloadcore-6ddecf61ecada646fbd6f8809270d47289727e8a.tar.gz
core-6ddecf61ecada646fbd6f8809270d47289727e8a.zip
fillUnoException not working on std::rethrow_exception exceptions
used since... commit dacc1b40df67d154c96b256b0d920460f38c3d11 Date: Sat Jul 28 16:33:22 2018 +0100 ofz#9597 rethrown IOException not caught by catch IOException the adjustedPtr seems to be as expected, but the type_info not. Presumably these are thrown as 'dependent exceptions' (?) https://github.com/gcc-mirror/gcc/blob/master/libstdc%2B%2B-v3/libsupc%2B%2B/eh_type.cc#L42 Change-Id: Ibd736abe941bb1d5facdb88139b3a0e6cf32cf1f Reviewed-on: https://gerrit.libreoffice.org/58477 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 25d85b435361..9a0c2c3083e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6028,6 +6028,17 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
+ AC_MSG_CHECKING([whether $CXX declares __cxa_current_exception_type in cxxabi.h])
+ AC_LANG_PUSH([C++])
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <cxxabi.h>
+ void * f() { return __cxxabiv1::__cxa_current_exception_type(); }
+ ])], [
+ AC_DEFINE([HAVE_CXXABI_H_CXA_CURRENT_EXCEPTION_TYPE],[1])
+ AC_MSG_RESULT([yes])
+ ], [AC_MSG_RESULT([no])])
+ AC_LANG_POP([C++])
+
AC_MSG_CHECKING([whether $CXX declares __cxa_throw in cxxabi.h])
AC_LANG_PUSH([C++])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([