summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-08-18 11:48:26 +0200
committerStephan Bergmann <sbergman@redhat.com>2016-08-18 12:52:23 +0000
commit6782d9991c942042c9a959b57355b4bbce5cb314 (patch)
tree4f7d6ad94612fd24d8d11943d78b8881abbce5b4 /configure.ac
parentAdd handling of a +RELATIVETIMER flag in the SAL_LOG environment variable (diff)
downloadcore-6782d9991c942042c9a959b57355b4bbce5cb314.tar.gz
core-6782d9991c942042c9a959b57355b4bbce5cb314.zip
external/firebird: Make GCC check work for Clang, too
Randomly approximate that HAVE_GXX_FNO_SIZED_DEALLOCATION also implies support for -fno-delete-null-pointer-checks, and hope that approximation matches the various versions of GCC and Clang that are relevant for us. Change-Id: I265bf3432a852a094318a54975403eac60721ab4 Reviewed-on: https://gerrit.libreoffice.org/28211 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 75b28b249271..6e1483688783 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6449,6 +6449,23 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
fi
AC_SUBST(HAVE_GCC_PRAGMA_OPERATOR)
+HAVE_GCC_FNO_FNO_SIZED_DEALLOCATION=
+if test "$GCC" = yes; then
+ AC_MSG_CHECKING([whether $CXX supports -fno-sized-deallocation])
+ AC_LANG_PUSH([C++])
+ save_CXXFLAGS=$CXXFLAGS
+ CXXFLAGS="$CXXFLAGS -fno-sized-deallocation"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM()],[HAVE_GCC_FNO_SIZED_DEALLOCATION=TRUE])
+ CXXFLAGS=$save_CXXFLAGS
+ AC_LANG_POP([C++])
+ if test "$HAVE_GCC_FNO_SIZED_DEALLOCATION" = TRUE; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+AC_SUBST([HAVE_GCC_FNO_SIZED_DEALLOCATION])
+
dnl ===================================================================
dnl system stl sanity tests
dnl ===================================================================