summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2019-01-30 15:10:56 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2019-01-30 20:32:18 +0100
commit191966900865bd720f356941cb392abf3538df31 (patch)
treebbf307fe8813e7cd6435a817706dfa91b8cf26b7 /configure.ac
parenttdf#122260 sc: Autofilters not properly cleared (diff)
downloadcore-191966900865bd720f356941cb392abf3538df31.tar.gz
core-191966900865bd720f356941cb392abf3538df31.zip
don't require /autoconf/ to be 2.68 (also allow e.g. autoconf268)
partially reverts 182f5a0f34fa45d2f74ba22eda41d4e39dca93e5 in the sense that configure still insists on autoconf 2.68, but in a way that allows to specify an already installed copy (that the libnumbertext build already picked up successfully) While there is autoconf268 package, it gets installed as autoconf268, but aclocal doesn't provide a way to use something else than "autoconf" In the spirit of "keeping it simple", no conditional check is done whether libnumbertext is actually enabled or not. Change-Id: Ice05a70ef56a4ed3428c74d15d6aeeaa54f71c0b Reviewed-on: https://gerrit.libreoffice.org/67159 Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7ececcaeb282..7297c72a1db9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,7 +11,12 @@ dnl in order to create a configure script.
AC_INIT([LibreOffice],[6.3.0.0.alpha0+],[],[],[http://documentfoundation.org/])
-AC_PREREQ([2.68])
+dnl libnumbertext needs autoconf 2.68, but that can pick up autoconf268 just fine if it is installed
+dnl whereas aclocal (as run by autogen.sh) insists on using autoconf and fails hard
+dnl so check for the version of autoconf that is actually used to create the configure script
+AC_PREREQ([2.59])
+m4_if(m4_version_compare(m4_defn([AC_AUTOCONF_VERSION]), [2.68]), -1,
+ [AC_MSG_ERROR([at least autoconf version 2.68 is needed (you can use AUTOCONF environment variable to point to a suitable one)])])
if test -n "$BUILD_TYPE"; then
AC_MSG_ERROR([You have sourced config_host.mk in this shell. This may lead to trouble, please run in a fresh (login) shell.])