summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKohei Yoshida <kohei.yoshida@collabora.com>2013-09-11 17:46:35 -0400
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2013-09-19 17:03:16 +0200
commit03f548e6fb74e83b32b59ba198e5c82e30320519 (patch)
tree3b18d60d64686f267615b6c53f33584ad0d4e41e /configure.ac
parentRemove opencl-sdk configure option, and build time opencl conditionals. (diff)
downloadcore-03f548e6fb74e83b32b59ba198e5c82e30320519.tar.gz
core-03f548e6fb74e83b32b59ba198e5c82e30320519.zip
Allow enable / disable opencl at build time.
Change-Id: I65e2a71aae8317930d1575e7d82c11c3fd2b74de
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 501e56d9ae0a..d9691c2d8b4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -917,6 +917,10 @@ AC_ARG_ENABLE(opengl,
AS_HELP_STRING([--disable-opengl],
[Determines whether to build the OpenGL 3D slide transitions component.]))
+AC_ARG_ENABLE(opencl,
+ AS_HELP_STRING([--disable-opencl],
+ [Determines whether to build with OpenCL support.]))
+
AC_ARG_ENABLE(dbus,
AS_HELP_STRING([--disable-dbus],
[Determines whether to enable features that depend on dbus.
@@ -10222,6 +10226,26 @@ fi
AC_SUBST(SYSTEM_MESA_HEADERS)
AC_SUBST(ENABLE_OPENGL)
+dnl =================================================
+dnl Check whether to build with OpenCL support.
+dnl =================================================
+
+AC_MSG_CHECKING([whether to build with the OpenCL support.])
+ENABLE_OPENCL=
+
+if test "x$enable_opencl" != "xno"; then
+ AC_MSG_RESULT([yes])
+ enable_opencl=yes
+ ENABLE_OPENCL=TRUE
+ AC_DEFINE(HAVE_FEATURE_OPENCL)
+else
+ AC_MSG_RESULT([no])
+ enable_opencl=no
+ ENABLE_OPENCL=FALSE
+fi
+
+AC_SUBST(ENABLE_OPENCL)
+
# presenter minimizer extension?
AC_MSG_CHECKING([whether to build the Presentation Minimizer extension])
if test "x$enable_ext_presenter_minimizer" != "xno" -a "x$enable_extension_integration" != "xno"; then