summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <michael.stahl@allotropia.de>2021-01-18 20:14:54 +0100
committerMichael Stahl <michael.stahl@allotropia.de>2021-01-22 11:30:30 +0100
commitfeb24353f59e49ebcb5ad1dae3ef275ea75bb689 (patch)
treef085bdbe37b3320e99c693935663a1c9b9c1e2e3 /configure.ac
parenttdf#135014 sw: fix crash exporting numbering to DOCX (diff)
downloadcore-feb24353f59e49ebcb5ad1dae3ef275ea75bb689.tar.gz
core-feb24353f59e49ebcb5ad1dae3ef275ea75bb689.zip
add --disable-librelogo to disable LibreLogo at build time
Annoyingly the packinfo_*.txt don't support conditionals but we can work-around that with a little duplication. Change-Id: Id00a6831effcc63a917fc21d2cd201474fdb559d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/109569 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de> (cherry picked from commit c18d3f8823a00edcd3dacec4f2052302ab6a70ee) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/109764 Tested-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97e3f49efc9c..0b7415549198 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1526,6 +1526,11 @@ AC_ARG_ENABLE(ldap,
[Disable LDAP support.]),
,enable_ldap=yes)
+libo_FUZZ_ARG_ENABLE(librelogo,
+ AS_HELP_STRING([--disable-librelogo],
+ [Do not build LibreLogo.]),
+,enable_librelogo=yes)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -8815,6 +8820,23 @@ AC_SUBST(PYTHON_VERSION)
AC_SUBST(PYTHON_VERSION_MAJOR)
AC_SUBST(PYTHON_VERSION_MINOR)
+AC_MSG_CHECKING([whether to build LibreLogo])
+case "$enable_python" in
+no|disable)
+ AC_MSG_RESULT([no; Python disabled])
+ ;;
+*)
+ if test "${enable_librelogo}" = "no"; then
+ AC_MSG_RESULT([no])
+ else
+ AC_MSG_RESULT([yes])
+ BUILD_TYPE="${BUILD_TYPE} LIBRELOGO"
+ AC_DEFINE([ENABLE_LIBRELOGO],1)
+ fi
+ ;;
+esac
+AC_SUBST(ENABLE_LIBRELOGO)
+
ENABLE_MARIADBC=TRUE
if test "$_os" = "Android" -o "$_os" = "iOS" -o "$enable_mpl_subset" = "yes"; then
ENABLE_MARIADBC=