summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2022-12-15 14:00:28 +0100
committerMichael Stahl <michael.stahl@allotropia.de>2023-02-08 14:06:06 +0000
commitfcb83bf3e2925915c6b614522fbf68da2f10ffb9 (patch)
treec951fb6b68f828c8e3a1290a7ac84562c0ada740 /configure.ac
parentShow LHM own BuildVersion without link to website (diff)
downloadcore-fcb83bf3e2925915c6b614522fbf68da2f10ffb9.tar.gz
core-fcb83bf3e2925915c6b614522fbf68da2f10ffb9.zip
don't export entries from download.lst - only used by make
no need to plant that into the environment of every recipe. some Jenkins Windows builders already run into "environment is too large for exec" issue just by attempting a "xargs --show-limits </dev/null" from a dummy rule within the make environment Reviewed-on: https://gerrit.libreoffice.org/c/core/+/144217 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> (cherry picked from commit ec4409a911fd4a67eb1bc74aae33081ae8510339) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/144325 Reviewed-by: Michael Stahl <michael.stahl@allotropia.de> (cherry picked from commit 70f0cf457bdd36e914f3e98cf027ee25a75df448) Cherry-pick part of commit d9617d5529e0da23bd8602d07ce459cc42746e02 to fix make module.clean. Change-Id: I321fa9075532eef62a7d4e33a08c272276de717e Reviewed-on: https://gerrit.libreoffice.org/c/core/+/146658 Tested-by: Michael Stahl <michael.stahl@allotropia.de> Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7547cc781a0b..4454ee7d0b21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7742,7 +7742,7 @@ if test "$with_export_validation" != "no"; then
ODFVALIDATOR="$BUILDDIR/bin/odfvalidator.sh"
# and fetch name of odfvalidator jar name from download.lst
- ODFVALIDATOR_JAR=`$SED -n -e "s/export *ODFVALIDATOR_JAR *:= *\(.*\) */\1/p" $SRC_ROOT/download.lst`
+ ODFVALIDATOR_JAR=`$SED -n -e "s/^ODFVALIDATOR_JAR *:= *\(.*\) */\1/p" $SRC_ROOT/download.lst`
AC_SUBST(ODFVALIDATOR_JAR)
if test -z "$ODFVALIDATOR_JAR"; then
@@ -7769,7 +7769,7 @@ if test "$with_export_validation" != "no"; then
OFFICEOTRON="$BUILDDIR/bin/officeotron.sh"
# and fetch name of officeotron jar name from download.lst
- OFFICEOTRON_JAR=`$SED -n -e "s/export *OFFICEOTRON_JAR *:= *\(.*\) */\1/p" $SRC_ROOT/download.lst`
+ OFFICEOTRON_JAR=`$SED -n -e "s/^OFFICEOTRON_JAR *:= *\(.*\) */\1/p" $SRC_ROOT/download.lst`
AC_SUBST(OFFICEOTRON_JAR)
if test -z "$OFFICEOTRON_JAR"; then