summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noelgrandin@gmail.com>2021-12-15 19:18:58 +0200
committerTor Lillqvist <tml@collabora.com>2021-12-20 12:58:09 +0100
commitb4f5f6187f5b09fb938a190eabd5fabe161a2c7b (patch)
tree7828f2bf882b521c7bb3103a26c9f6f0862d8da4 /configure.ac
parentAccept iOS SDK 15.2 (diff)
downloadcore-b4f5f6187f5b09fb938a190eabd5fabe161a2c7b.tar.gz
core-b4f5f6187f5b09fb938a190eabd5fabe161a2c7b.zip
add support for macOS SDK 12.1
Change-Id: I30d816d5926e5b1771901c697b67eb275d122636 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/126890 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/127137 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6a2d58cec530..143d04870758 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3126,7 +3126,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-12.0 11.3 11.1 11.0 10.15 10.14 10.13}; do
+ for _macosx_sdk in ${with_macosx_sdk-12.1 12.0 11.3 11.1 11.0 10.15 10.14 10.13}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -3167,8 +3167,11 @@ if test $_os = Darwin; then
12.0)
MACOSX_SDK_VERSION=120000
;;
+ 12.1)
+ MACOSX_SDK_VERSION=120100
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--12.0])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--12.1])
;;
esac
@@ -3239,8 +3242,11 @@ if test $_os = Darwin; then
12.0)
MAC_OS_X_VERSION_MIN_REQUIRED="120000"
;;
+ 12.1)
+ MAC_OS_X_VERSION_MIN_REQUIRED="120100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--12.0])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--12.1])
;;
esac
@@ -3310,8 +3316,11 @@ if test $_os = Darwin; then
12.0)
MAC_OS_X_VERSION_MAX_ALLOWED="120000"
;;
+ 12.1)
+ MAC_OS_X_VERSION_MAX_ALLOWED="120100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--12.0])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--12.1])
;;
esac