summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-07-30 13:40:52 +0200
committerMichael Stahl <Michael.Stahl@cib.de>2019-07-31 16:51:30 +0200
commitb3f72cd239e5a9d7f863bded46d6fc902a4c570c (patch)
treea8357457bbe9e4e5e83f97e82a8a32a742fada38 /configure.ac
parentremove LibreLogo from build (diff)
downloadcore-b3f72cd239e5a9d7f863bded46d6fc902a4c570c.tar.gz
core-b3f72cd239e5a9d7f863bded46d6fc902a4c570c.zip
sysui: fix rpm errors in freedesktop-menus (4.14.1)
RPM build errors: Explicit %attr() mode not applicable to symlink: /workdir/CustomTarget/sysui/rpm/libreofficedev/freedesktop/usr/bin/libreofficedev6.1 Installed (but unpackaged) file(s) found: /usr/local/lib/girepository-1.0/LOKDocView-0.1.typelib /usr/share/gir-1.0/LOKDocView-0.1.gir The LOKDocView problem turned out to be the result of the first incremental build after adding --with-package-format, and previously it was avoided with a if in configure; moving the commands out of create_tree.sh should be more obvious and reliable though. Change-Id: I69c1566e26eeaa1d8bf88a3650a78da6ddfb5a3b Reviewed-on: https://gerrit.libreoffice.org/76596 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> (cherry picked from commit 634844354ee6ed884128086a80c3ee32c889d8c9)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b2a074b5bc8e..7ebdc176ed9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9984,10 +9984,7 @@ if test "x$enable_gtk3" = "xyes"; then
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.18 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then
R="gtk3"
- dnl Avoid installed by unpackaged files for now.
- if test -z "$PKGFORMAT"; then
- GOBJECT_INTROSPECTION_CHECK(INTROSPECTION_REQUIRED_VERSION)
- fi
+ GOBJECT_INTROSPECTION_CHECK(INTROSPECTION_REQUIRED_VERSION)
else
AC_MSG_ERROR([gtk3 or dependent libraries of the correct versions, not found])
fi