summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-04-11 09:20:13 +0200
committerGabor Kelemen <kelemeng@ubuntu.com>2021-12-21 09:14:57 +0100
commit705ebb8b8e02d649d96c3416308944c08a9e6c56 (patch)
tree60f3960e9c7fb3b857fa81c56067591dfeabcb23 /configure.ac
parentexternal/jfreereport: Get rid of apache-commons-logging (diff)
downloadcore-705ebb8b8e02d649d96c3416308944c08a9e6c56.tar.gz
core-705ebb8b8e02d649d96c3416308944c08a9e6c56.zip
Get rid of apache-commons-logging
...using Java 1.4 java.util.logging.Logger instead also for the last remaining uses in reportbuilder. (The mention in swext/mediawiki/src/THIRDPARTYLICENSEREADME.html was presumably a leftover from 4b6ceed4a4a9b152905a8b1712ffb9bd61373c16 "swext: Wiki Publisher does not use those apache-commons libraries".) Change-Id: Ia0bc598fe5844ced11cae497548ec7d09453a99d Reviewed-on: https://gerrit.libreoffice.org/c/core/+/113939 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/127198 Tested-by: Gabor Kelemen <kelemeng@ubuntu.com> Reviewed-by: Gabor Kelemen <kelemeng@ubuntu.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index 76125b12667f..a37e91860bdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1710,11 +1710,6 @@ AC_ARG_WITH(system-gpgmepp,
[Use gpgmepp already on system]),,
[with_system_gpgmepp="$with_system_libs"])
-AC_ARG_WITH(system-apache-commons,
- AS_HELP_STRING([--with-system-apache-commons],
- [Use Apache commons libraries already on system.]),,
- [with_system_apache_commons="$with_system_jars"])
-
AC_ARG_WITH(system-mariadb,
AS_HELP_STRING([--with-system-mariadb],
[Use MariaDB/MySQL libraries already on system, for building the MariaDB Connector/LibreOffice
@@ -1798,11 +1793,6 @@ AC_ARG_WITH(rhino-jar,
[Specify path to jarfile manually.]),
RHINO_JAR=$withval)
-AC_ARG_WITH(commons-logging-jar,
- AS_HELP_STRING([--with-commons-logging-jar=JARFILE],
- [Specify path to jarfile manually.]),
- COMMONS_LOGGING_JAR=$withval)
-
AC_ARG_WITH(system-jfreereport,
AS_HELP_STRING([--with-system-jfreereport],
[Use JFreeReport already on system.]),,
@@ -10658,35 +10648,6 @@ AC_SUBST(LIBREPOSITORY_JAR)
AC_SUBST(LIBFONTS_JAR)
AC_SUBST(LIBSERIALIZER_JAR)
-# this has to be here because both the Wiki Publisher and the SRB use
-# commons-logging
-COMMONS_LOGGING_VERSION=1.2
-if test "$ENABLE_REPORTBUILDER" = "TRUE"; then
- AC_MSG_CHECKING([which Apache commons-* libs to use])
- if test "$with_system_apache_commons" = "yes"; then
- SYSTEM_APACHE_COMMONS=TRUE
- AC_MSG_RESULT([external])
- if test -z $COMMONS_LOGGING_JAR; then
- if test -f /usr/share/java/commons-logging-${COMMONS_LOGGING_VERSION}.jar; then
- COMMONS_LOGGING_JAR=/usr/share/java/commons-logging-${COMMONS_LOGGING_VERSION}.jar
- elif test -f /usr/share/java/commons-logging.jar; then
- COMMONS_LOGGING_JAR=/usr/share/java/commons-logging.jar
- else
- AC_MSG_ERROR(commons-logging.jar replacement not found.)
- fi
- elif ! test -f $COMMONS_LOGGING_JAR; then
- AC_MSG_ERROR(commons-logging.jar not found.)
- fi
- else
- AC_MSG_RESULT([internal])
- SYSTEM_APACHE_COMMONS=
- BUILD_TYPE="$BUILD_TYPE APACHE_COMMONS"
- fi
-fi
-AC_SUBST(SYSTEM_APACHE_COMMONS)
-AC_SUBST(COMMONS_LOGGING_JAR)
-AC_SUBST(COMMONS_LOGGING_VERSION)
-
# scripting provider for BeanShell?
AC_MSG_CHECKING([whether to build support for scripts in BeanShell])
if test "${enable_scripting_beanshell}" != "no" -a "x$with_java" != "xno"; then