summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-11-27 21:27:28 +0100
committerMichael Stahl <mstahl@redhat.com>2014-11-27 21:29:00 +0100
commit20d1e20d16ac377c160d47b53ff487a75fbd166f (patch)
treea152ba924c981ed475d6290c745d65512670fe10 /configure.ac
parentfix few problems (diff)
downloadcore-20d1e20d16ac377c160d47b53ff487a75fbd166f.tar.gz
core-20d1e20d16ac377c160d47b53ff487a75fbd166f.zip
configure: do not default to system libjpeg on Linux
There are multiple different sonames of libjpeg in different distros, so use a system one only when system libs are requested. Change-Id: I164433a31ab0fb4723da6843eb1f1132c8447d9e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 52cff0548973..27d6bd6d2ef4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1574,7 +1574,7 @@ AC_ARG_WITH(system-zlib,
AC_ARG_WITH(system-jpeg,
AS_HELP_STRING([--with-system-jpeg],
[Use jpeg already on system.]),,
- [with_system_jpeg=auto])
+ [with_system_jpeg="$with_system_libs"])
AC_ARG_WITH(system-libgltf,
AS_HELP_STRING([--with-system-libgltf],
@@ -7330,18 +7330,6 @@ AC_SUBST(SYSTEM_ZLIB)
dnl ===================================================================
dnl Check for system jpeg
dnl ===================================================================
-AC_MSG_CHECKING([which jpeg to use])
-if test "$with_system_jpeg" = "auto"; then
- case "$_os" in
- WINNT|Darwin|iOS|Android)
- with_system_jpeg="$with_system_libs"
- ;;
- *)
- with_system_jpeg=yes
- ;;
- esac
-fi
-
if test "$with_jpeg_turbo" = "auto"; then
# TODO use jpeg-turbo on Darwin too
case "$_os" in