summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-02-22 09:39:57 +0200
committerTor Lillqvist <tml@collabora.com>2017-02-22 12:59:45 +0200
commitb514a0ecdf368e39033c53f312bee7c5e86939e0 (patch)
tree88a6b3966b0dc1d6c569e226866a1a13da5d203c /configure.ac
parentDrop .uno:ToggleTitle - this seems to be its only occurrence left (diff)
downloadcore-b514a0ecdf368e39033c53f312bee7c5e86939e0.tar.gz
core-b514a0ecdf368e39033c53f312bee7c5e86939e0.zip
Add --with-package-version option, mainly for non-TDF product macOS builds
For macOS, the "package" version is included in files generated by the build (the Info.plist), so we need to be able to set that at build time, in order to be able to produce differently identified builds from upstream sources with the same upstream package versions. Change-Id: Ieb6b6c07788178b629d6cff0630e30224f6e7ccd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4f3872e737e7..0928c1527102 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,7 +168,13 @@ dnl ===================================================================
dnl Our version is defined by the AC_INIT() at the top of this script.
dnl ===================================================================
-set `echo AC_PACKAGE_VERSION | sed "s/\./ /g"`
+AC_MSG_CHECKING([for package version])
+if test -n "$with_package_version" -a "$with_package_version" != no; then
+ PACKAGE_VERSION="$with_package_version"
+fi
+AC_MSG_RESULT([$PACKAGE_VERSION])
+
+set `echo "$PACKAGE_VERSION" | sed "s/\./ /g"`
LIBO_VERSION_MAJOR=$1
LIBO_VERSION_MINOR=$2
@@ -1447,6 +1453,11 @@ AC_ARG_WITH(product-name,
[Define the product name. Default is AC_PACKAGE_NAME.]),
,with_product_name=$PRODUCTNAME)
+AC_ARG_WITH(package-version,
+ AS_HELP_STRING([--with-package-version='3.1.4.5'],
+ [Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
+,)
+
AC_ARG_ENABLE(ios-simulator,
AS_HELP_STRING([--enable-ios-simulator],
[Build for the iOS Simulator, not iOS device.]),