summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-02-23 10:09:37 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-02-23 10:09:37 +0100
commit78a2e5b5c59c2f3a3e117a098dbbcf518fba2e85 (patch)
tree56ecdf9d09aedc43123d8a2a8f36a8474263f17b /configure.ac
parentofz#663 leak in svm comment reader (diff)
downloadcore-78a2e5b5c59c2f3a3e117a098dbbcf518fba2e85.tar.gz
core-78a2e5b5c59c2f3a3e117a098dbbcf518fba2e85.zip
HAVE_GCC_PRAGMA_OPERATOR is only needed as AC_DEFINE
Change-Id: I1f1978bbc8c38a7d5504fb86b8a716cbbc01c830
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7408f7b26aef..7c33f193ad1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6319,7 +6319,6 @@ if test "$cxx11_utf16_string_literal" = yes; then
AC_DEFINE([HAVE_CXX11_UTF16_STRING_LITERAL])
fi
-HAVE_GCC_PRAGMA_OPERATOR=
dnl _Pragma support (may require C++11)
if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_CHECKING([whether $CXX supports _Pragma operator])
@@ -6330,13 +6329,11 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
_Pragma("GCC diagnostic ignored \"-Wformat\"")
])], [
AC_DEFINE([HAVE_GCC_PRAGMA_OPERATOR],[1])
- HAVE_GCC_PRAGMA_OPERATOR=1
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
CXXFLAGS=$save_CXXFLAGS
fi
-AC_SUBST(HAVE_GCC_PRAGMA_OPERATOR)
HAVE_GCC_FNO_SIZED_DEALLOCATION=
if test "$GCC" = yes; then