summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2013-07-18 12:41:08 +0200
committerFridrich Strba <fridrich@documentfoundation.org>2013-07-19 08:04:11 +0000
commitf351c1399313aab9533bd9b0451a1e7fd76e2204 (patch)
tree6cf4d788b8d0bfaccc1ac188aa619c5ebb41b0cd /configure.ac
parentRemove duplicate propertyids.[hc]xx. (diff)
downloadcore-f351c1399313aab9533bd9b0451a1e7fd76e2204.tar.gz
core-f351c1399313aab9533bd9b0451a1e7fd76e2204.zip
allow to build for Windows XP when using Visual Studio 2012
VS 2012 Update 1 added the possibility to target Windows XP by using a SDK that is based on the Windows 7 one. http://blogs.msdn.com/b/vcblog/archive/2012/10/08/10357555.aspx This patch probably should not be integrated as is, as it disables a test that fails in this configuration (CppunitTest_connectivity_ado) Change-Id: I3ba8723882452950c40049ccdc95b04c60862cbf Reviewed-on: https://gerrit.libreoffice.org/4966 Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org> Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5894618ab9da..95fc3008bac3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3250,7 +3250,7 @@ if test "$_os" = "WINNT"; then
;;
110)
COMEX=14
- WINDOWS_SDK_ACCEPTABLE_VERSIONS="8.0"
+ WINDOWS_SDK_ACCEPTABLE_VERSIONS="8.0 7.1A"
;;
esac
@@ -9234,6 +9234,13 @@ the Windows SDK are installed.])
elif echo $WINDOWS_SDK_HOME | grep "8.0" >/dev/null 2>/dev/null; then
WINDOWS_SDK_VERSION=80
AC_MSG_RESULT([found Windows SDK 8.0 ($WINDOWS_SDK_HOME)])
+ # compatibility warning if usind VS 2012 and not explicitly choosing the 80 SDK
+ if test "$VCVER" = "110" -a -z "$with_windows_sdk"; then
+ AC_MSG_WARN([If a build created with VS 2012 should run on Windows XP,])
+ AC_MSG_WARN([use --with-windows-sdk=7.1A (requires VS 2012 Update 1 or newer)])
+ add_warning "If a build created with VS 2012 should run on Windows XP,"
+ add_warning "use --with-windows-sdk=7.1A (requires VS 2012 Update 1 or newer)"
+ fi
else
AC_MSG_ERROR([Found legacy Windows Platform SDK ($WINDOWS_SDK_HOME)])
fi
@@ -9259,6 +9266,9 @@ the Windows SDK are installed.])
WINDOWS_SDK_WILANGID=$WINDOWS_SDK_HOME/bin/$WINDOWS_SDK_ARCH/WiLangId.vbs
fi
if ! test -e "$WINDOWS_SDK_WILANGID" ; then
+ WINDOWS_SDK_WILANGID=$(cygpath -sm "C:/Program Files (x86)/Windows Kits/8.0/bin/$WINDOWS_SDK_ARCH/WiLangId.vbs")
+ fi
+ if ! test -e "$WINDOWS_SDK_WILANGID" ; then
AC_MSG_WARN([WiLangId.vbs not found - building translated packages will fail])
add_warning "WiLangId.vbs not found - building translated packages will fail"
fi