summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSiqi <me@siqi.fr>2013-07-24 11:16:31 +0200
committerSiqi LIU <me@siqi.fr>2013-07-25 17:28:01 +0200
commitd041980a7aad0e6d111752ca98db42f9853a3c6b (patch)
treeb3a03f624d335baf19d38dd633361d331ae63479 /configure.ac
parentprevent zeroconf discovery duplication (diff)
downloadcore-d041980a7aad0e6d111752ca98db42f9853a3c6b.tar.gz
core-d041980a7aad0e6d111752ca98db42f9853a3c6b.zip
avahi patch
Change-Id: I782389f00f486158313fd87bd36c0726f56f6ab6 Signed-off-by: Siqi LIU <me@siqi.fr>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f59a1b6c205..9f753042f34e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -942,6 +942,11 @@ AC_ARG_ENABLE(gio,
[Determines whether to use the GIO support.]),
,enable_gio=yes)
+AC_ARG_ENABLE(avahi,
+ AS_HELP_STRING([--disable-avahi],
+ [Determines whether to use the avahi support for impress remote zeroconf.]),
+,enable_avahi=yes)
+
AC_ARG_ENABLE(telepathy,
AS_HELP_STRING([--enable-telepathy],
[Determines whether to enable Telepathy for collaboration.]),
@@ -11381,6 +11386,25 @@ AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)
dnl ===================================================================
+dnl Test whether to use avahi
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable avahi support])
+if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_avahi" = "yes"; then
+ PKG_CHECK_MODULES([AVAHI], [avahi-client >= 0.6.10],
+ [ENABLE_AVAHI="TRUE"], [ENABLE_AVAHI=""])
+ if test "$ENABLE_AVAHI" = "TRUE"; then
+ AC_DEFINE(ENABLE_AVAHI)
+ AVAHI_CFLAGS=$(printf '%s' "$AVAHI_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+ fi
+else
+ AC_MSG_RESULT([no])
+fi
+
+AC_SUBST(ENABLE_AVAHI)
+AC_SUBST(AVAHI_CFLAGS)
+AC_SUBST(AVAHI_LIBS)
+
+dnl ===================================================================
dnl Test whether to use liblangtag
dnl ===================================================================
ENABLE_LIBLANGTAG=