summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-08-30 13:18:04 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2013-08-30 19:59:18 +0000
commitac5f2f3481a318cadd7c59e7ea89401f81e9a259 (patch)
tree1919c6231508bac01e26c1353b8b3ab761f8b82f /configure.ac
parentENABLE_SCRIPTING_* Harmonize ENABLE_* variable to TRUE/<nothing> (diff)
downloadcore-ac5f2f3481a318cadd7c59e7ea89401f81e9a259.tar.gz
core-ac5f2f3481a318cadd7c59e7ea89401f81e9a259.zip
ENABLE_RELEASE_BUILD Harmonize ENABLE_* variable to TRUE/<nothing>
Change-Id: I7387ff3d3adf9a4e7c15466076e9d84d4892bb3e Reviewed-on: https://gerrit.libreoffice.org/5703 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index be7ddd7f2b00..b2ab0ef12792 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1983,10 +1983,10 @@ dnl ===================================================================
AC_MSG_CHECKING([whether build target is Release Build])
if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
AC_MSG_RESULT([no])
- ENABLE_RELEASE_BUILD="FALSE"
+ ENABLE_RELEASE_BUILD=
else
AC_MSG_RESULT([yes])
- ENABLE_RELEASE_BUILD="TRUE"
+ ENABLE_RELEASE_BUILD=TRUE
fi
AC_SUBST(ENABLE_RELEASE_BUILD)
@@ -5112,11 +5112,11 @@ find_msms()
msmdir=`cygpath -d "$msmdir"`
msmdir=`cygpath -u "$msmdir"`
if test -z "$msmdir"; then
- if test "$ENABLE_RELEASE_BUILD" = "FALSE" ; then
+ if test "$ENABLE_RELEASE_BUILD" = "TRUE" ; then
+ AC_MSG_ERROR([Merge modules not found in $msmdir])
+ else
AC_MSG_WARN([Merge modules not found in $msmdir])
msmdir=""
- else
- AC_MSG_ERROR([Merge modules not found in $msmdir])
fi
else
msms="Microsoft_VC${VCVER}_CRT_x86.msm"
@@ -11191,7 +11191,7 @@ AC_MSG_CHECKING([which themes to include])
# if none given use default subset of available themes
if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
with_theme="crystal default hicontrast oxygen tango sifr"
- test "$ENABLE_RELEASE_BUILD" = "FALSE" && with_theme="$with_theme tango_testing"
+ test -z "$ENABLE_RELEASE_BUILD" && with_theme="$with_theme tango_testing"
fi
WITH_THEMES=""