summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Meeks <michael.meeks@suse.com>2013-08-06 16:52:04 +0200
committerMichael Meeks <michael.meeks@suse.com>2013-08-06 16:53:22 +0200
commit7b4bdab8252200e89a05294bdcdebef2ab9feb81 (patch)
treec517a6ff177c8fc979a16a0024451357c7df73d3 /configure.ac
parentfdo#67707 - avoid crash with sidebar when switching to writer from impress. (diff)
downloadcore-7b4bdab8252200e89a05294bdcdebef2ab9feb81.tar.gz
core-7b4bdab8252200e89a05294bdcdebef2ab9feb81.zip
MPLv2 subset improvement.
Change-Id: I96efcab67f05407923b022dfd95a94fd8c2169ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ed63e26137d..93e23169d916 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12247,6 +12247,15 @@ AC_MSG_CHECKING([MPL subset])
MPL_SUBSET=
if test "$enable_mpl_subset" = "yes"; then
+ warn_report=false
+ if test "$enable_report_builder" != "no" -a "$with_java" != "no"; then
+ warn_report=true
+ elif test "x$ENABLE_REPORTBUILDER" = "xTRUE"; then
+ warn_report=true
+ fi
+ if test "$warn_report" = "true"; then
+ AC_MSG_ERROR([need to --disable-report-builder - extended database report builder.])
+ fi
if test "x$enable_postgresql_sdbc" != "xno"; then
AC_MSG_ERROR([need to --disable-postgresql-sdbc - the postgress database backend.])
fi