summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-08-02 18:13:12 +0300
committerTor Lillqvist <tml@iki.fi>2013-08-02 18:13:12 +0300
commit64ddbd26a58fd84b56b270c21411ce7c246081ef (patch)
tree6cf32550f848d0e8b8fa381b7cd8e5b3cf8cd05c /configure.ac
parentIndentation cleanup (diff)
downloadcore-64ddbd26a58fd84b56b270c21411ce7c246081ef.tar.gz
core-64ddbd26a58fd84b56b270c21411ce7c246081ef.zip
Enforce no Java if sandboxed
Change-Id: I3c58684cc3914d8f7554c87d8d9e0735e95ea381
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac68
1 files changed, 35 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index fff3f0728a28..bc6ddb5b0952 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1136,8 +1136,8 @@ AC_ARG_ENABLE(macosx-code-signing,
AC_ARG_ENABLE(macosx-sandbox,
AS_HELP_STRING([--enable-macosx-sandbox],
[Make the app bundle run in a sandbox. Requires code signing.
- The default is to not do this. Experimental work in progress,
- don't use unless you are working on this.]),
+ Is required by apps distributed in the Mac App Store, and implies
+ adherence to App Store rules.]),
,)
AC_ARG_WITH(macosx-bundle-identifier,
@@ -2431,6 +2431,37 @@ fi
AC_SUBST(ENABLE_LTO)
dnl ===================================================================
+dnl Java support enable
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build with Java support])
+if test "$with_java" != "no"; then
+ if test "$DISABLE_SCRIPTING" = TRUE; then
+ AC_MSG_RESULT([no, overridden by --disable-scripting])
+ SOLAR_JAVA=""
+ with_java=no
+ else
+ AC_MSG_RESULT([yes])
+ SOLAR_JAVA="TRUE"
+ fi
+else
+ AC_MSG_RESULT([no])
+ SOLAR_JAVA=""
+fi
+
+AC_SUBST(SOLAR_JAVA)
+
+dnl SOLAR_JAVA="YES" (yes, silly name, should rename) indicates whether we
+dnl want there to be *run-time* (and build-time) support for Java extensions in the
+dnl built LibreOffice.
+
+dnl SOLAR_JAVA="BUILD" is claimed to indicate build-time only support
+dnl (no runtime support). It doesn't seem to ever be set to this
+dnl value, though, and everywhere SOLAR_JAVA is only checked for being
+dnl empty or non-empty.
+
+dnl SOLAR_JAVA="" indicate no java support at all
+
+dnl ===================================================================
dnl Test the Solaris compiler version
dnl ===================================================================
if test "$_os" = "SunOS"; then
@@ -2731,6 +2762,8 @@ if test $_os = Darwin; then
if test -z "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([OS X sandboxing requires code signing])
+ elif test -n "$SOLAR_JAVA" -a "$enable_macosx_sandbox" = yes; then
+ AC_MSG_ERROR([OS X sandboxing (actually App Store rules) disallows use of Java])
elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
ENABLE_MACOSX_SANDBOX=YES
AC_DEFINE(HAVE_FEATURE_MACOSX_SANDBOX)
@@ -6242,37 +6275,6 @@ else
fi
AC_SUBST(BUILD_VER_STRING)
-dnl ===================================================================
-dnl Java support enable
-dnl ===================================================================
-AC_MSG_CHECKING([whether to build with Java support])
-if test "$with_java" != "no"; then
- if test "$DISABLE_SCRIPTING" = TRUE; then
- AC_MSG_RESULT([no, overridden by --disable-scripting])
- SOLAR_JAVA=""
- with_java=no
- else
- AC_MSG_RESULT([yes])
- SOLAR_JAVA="TRUE"
- fi
-else
- AC_MSG_RESULT([no])
- SOLAR_JAVA=""
-fi
-
-AC_SUBST(SOLAR_JAVA)
-
-dnl SOLAR_JAVA="YES" (yes, silly name, should rename) indicates whether we
-dnl want there to be *run-time* (and build-time) support for Java extensions in the
-dnl built LibreOffice.
-
-dnl SOLAR_JAVA="BUILD" is claimed to indicate build-time only support
-dnl (no runtime support). It doesn't seem to ever be set to this
-dnl value, though, and everywhere SOLAR_JAVA is only checked for being
-dnl empty or non-empty.
-
-dnl SOLAR_JAVA="" indicate no java support at all
-
JITC_PROCESSOR_TYPE=""
if test "$_os" = "Linux" -a "$host_cpu" = "powerpc"; then
# IBMs JDK needs this...